Validación de Datos
de Entrada
Sin respuesta ante dato inválido
Enunciado: …
Entrada: datos x, de tipo t, cumpliendo p(x)
Salida: …
Objetivo: …
Observaciones: si la entrada x no cumple p(x), no se responde
inicio
leer datos
si datos válidos entonces
procesar datos
fin_si
fin
Sin respuesta ante dato inválido
Enunciado: …
Entrada: n, un número entero estrictamente positivo
Salida: …
Objetivo: …
Observaciones: si la n<=0, no se responde
begin
read (n);
if n > 0 then
(* procesar n *)
end .
Mensaje de datos inválidos
Enunciado: …
Entrada: datos x, de tipo t, cumpliendo p(x)
…
Observaciones: si no p(x), se responde con un mensaje indicativo
inicio
leer datos
si datos válidos entonces
procesar datos
si_no
escribir mensaje de datos inválidos
fin_si
fin
Mensaje de datos inválidos
Enunciado: …
Entrada: n, un número entero estrictamente positivo
…
Observaciones: si n<=0, se responde con un mensaje indicativo
begin
read (n);
if n > 0 then
(* procesar n *)
else
writeln (‘El número es incorrecto.’)
end.
Obtención de datos válidos
Enunciado: …
Entrada: datos x, de tipo t, cumpliendo p(x)
…
Observaciones: si no p(x), se repite la petición de datos
inicio
repetir
leer datos
hasta_que los datos sean válidos
procesar datos
fin
Obtención de datos válidos
Enunciado: …
Entrada: n, un número entero estrictamente positivo
…
Observaciones: si n<=0, se repite la petición de datos
begin
repeat
read (n);
until n > 0;
(* procesar n *)
end.
Obtención de datos válidos con mensaje
Enunciado: …
Entrada: datos x, de tipo t, cumpliendo p(x)
…
Observaciones: si no p(x), se repite la petición de datos informando
con un mensaje indicativo
inicio
leer datos
mientras datos inválidos hacer
escribir mensaje de error
leer datos
fin_mientras
procesar datos
fin
Obtención de datos válidos con mensaje
Enunciado: …
Entrada: n, un número entero estrictamente positivo
…
Observaciones: si n<=0, se repite la petición de datos informando con
un mensaje indicativo
begin
read (n);
while n <= 0 do
begin
writeln (‘El número debe ser positivo:’);
read (n)
end
(* procesar n *)
end.
Descargar

Validación