Estructuras Algorítmicas
Selectivas
MSc. Karla Largaespada Obando
Objetivos
• Conocer las estructuras que nos permitan
tomar una decisión en la solución de un
problema.
• Verificar el nivel de asimilación por parte
de los estudiantes a través de una
evaluación.
Estructuras Selectivas
• Se utilizan cuando se debe tomar una
decisión en el desarrollo de la solución de
un problema. La toma de decisión se basa
en la evaluación de una o más
condiciones que nos señalarán como
consecuencia la rama a seguir.
Estructura Selectiva Simple IF
• Permite que el flujo del diagrama siga por
un camino especifico si se cumple una
condición determinada.
No Falso
Condición
Si Verdadero
Operación
• En pseudocódigo:
Si (condición) entonces
sentencias;
Ejemplo:
• Solicitar al usuario el promedio de la
asignatura de Introducción a la
programación, escribir «Aprobado» si es
mayor o igual a 60.
PSEUDOCODIGO
Inicio
Leer Promedio
Si promedio >=60
Imprimir “Aprobado”
Fin si
Fin
Ejemplo # 2
• Escribe un algoritmo que reciba como
dato el precio de un producto e
incremente en 11% el mismo si es inferior
a 1,500 y escriba el nuevo precio del
producto.
Estructura Selectiva Doble IfElse
• Permite que el diagrama de flujo se
bifurque para dos ramas diferentes en el
punto de la toma de decisión. Si al evaluar
la condición el resultado es verdadero,
entonces se sigue por un camino, pero si
el resultado es falso, se sigue por otro
camino y se realizan otras acciones.
PSEUDOCODIGO
Inicio
Leer Promedio
Si promedio >=60
Imprimir “Aprobado”
En caso contrario
Imprimir Reprobado
Fin si
Fin
Ejemplo # 2
• Escribe un algoritmo que reciba como
dato el precio de un producto e
incremente en 11% el mismo si es inferior
a 1,500 y escriba el nuevo precio del
producto y 8% si fuera mayor o igual a
dicho precio. Además escribir el nuevo
precio del producto.
Ejercicios de Consolidación
• Escribe un programa que reciba como dato de
entrada un numero entero y determine si el
numero es par o impar. Un numero es par si num
% 2 = 0.
• Solicite dos números al usuario y determine cuál
es el mayor.
• Calcular el precio del billete ida y vuelta en
ferrocarril, conociendo la distancia entre las dos
ciudades y el tiempo de estancia en la ciudad
destino. Si el numero de días de estancia es
superior a 10 y la distancia total (ida y vuelta) a
recorrer es superior a 500 km, el precio del billete
se reduce 20%. El precio por km es de C$0.50
Descargar

Tema_4_IF - WordPress.com