Laboratorio I:
Configuración de eclipse
Eclipse
entorno de programación desarrollado por la
Eclipse Foundation
– entorno de programación:
es un conjunto de herramientas para el desarrollo de
aplicaciones
utilizable con diferentes lenguajes de
programación
desarrollado en java
open-source
Antes de arrancar Eclipse…
Eclipse es un programa java
– Debe estar instalado el
JRE: Java Runtime Environment
software para que se puedan ejecutar programas
java
Comprueba la versión de java instalada en tu
equipo visitando esta dirección:
http://www.java.com/es/download/installed.jsp
– Y si no…
Comprobar la versión de java …
– Abre una ventana del sistema:
Inicio > Programas > Accesorios >
Símbolo del sistema
1. Escribe
java –version
1. Pulsa Enter
2. Verás cuál es la
versión de java
instalada
Si la versión instalada es anterior,
descarga e instala la última versión
http://www.java.com/es/download/
Para instalar Eclipse: descargar
Disponible en www.eclipse.org
Descargar
Eclipse Classic
suele estar por
ahí abajo…
Para instalar Eclipse:
descomprimir…
el.zip descargado…
Eclipse instalado
Comprueba que se ha creado una carpeta
con este contenido
•Para arrancar pinchar ese icono
•Puedes crear un acceso directo en
el Escritorio o en el Menú de Inicio
Puedes mover esa carpeta donde desees:
¿C > Archivos de programa?
Arrancar Eclipse
Al cabo de unos
segundos verás
Con alguna versión de Eclipse,
igual no sale eso:
si ocurre, salta hasta la diapositiva
con la pantalla de inicio
Eclipse almacena todos los archivos en una
carpeta: el workspace
Puedes cambiar su localización pinchando
Browse
En futuras sesiones…
Selecciona la carpeta con tu workspace
– No muevas la carpeta con el workspace a
mano… y no la crees en un pen-drive!
Después de elegir el workspace
Pincha en OK
Eclipse en marcha…
Si es la primera sesión,
– verás la pantalla de inicio/bienvenida:
pincha aquí
La pantalla de trabajo
Normalment
e aparecerá
algo
parecido a
esta pantalla
Creación de un proyecto
Pincha:
File > New > Project >
Java Project
no es necesario que crees
nuevos proyectos
Puedes crear todos los
programas que quieras en
el mismo proyecto
Igual es buena idea tener
más de un proyecto: para
cada capítulo, …
File > … > Java Project?
Pincha Next
Verás…
En versiones
anteriores de
Eclipse…
En Eclipse 3.5
¡Importante!
Debe estar seleccionado jre 1.5 o
posterior
Habilitar default JRE
Si es anterior, salir y
volver a empezar
después de instalar
la última versión de
java
Rellenar el formulario
Introduce el nombre del
proyecto; por ejemplo:
ProgramacionI
Selección activada
Si los campos del formulario
están rellenados según se
indica
Pincha Finish
El proyecto está creado…
El nombre
del
proyecto
Comprobar el proyecto: importante
Seleccionar
Build Automatically
El primer programa…
Pichar
File > New > Class
Rellenar formulario
•Lo que pones ahí es el
nombre de paquete
• por ejemplo:
Apellido.Nombre
Lo que pones ahí es el
nombre del programa
Habilitar selección!
…pero no siempre se hace!
El primer programa…
Si no aparece eso…
Entonces…
1. Pinchar ahí con el botón
derecho
2. Seleccionar Delete
Y volver a empezar File > New >…
El primer programa…
Esto es un comentario
desde /*
hasta */
Esto es otro comentario
desde //
hasta el fin de la línea
Entre las dos llaves, el código
Sólo ahí!
Los comentarios no son parte del código del programa
Sirven para ponerle explicaciones
El primer programa…
Entre las dos llaves, vamos a escribir
una lista de instrucciones
System.out.print("Hola");
System.out.println(" arranca… ");
System.out.print("… termina");
System.out.println(" y Fin!");
1. Copy y Paste!
2. Source > Format
Comprobación…
•El formato de los márgenes y demás, es importante
•Si no está así, pinchar en Source > Format
(¡H!)errare…
Un lenguaje de programación es una notación que
debe usarse respetando todas las reglas!
1. Cambiar dobles comillas por dos
apóstrofes
2. Salvar
3. Aparecen las marcas rojas
Indican que el texto no respeta las
Colocar el puntero en esa marca para
reglas del lenguaje
tener más información sobre el error
Ejecutando el programa…
Después de corregir, pulsar
Run > Run As > Java Application
Si no se ve la pestaña
Window > Show View > Console
En la pestaña Console aparecen los resultados
del programa
System.out.print y System.out.println
hacen cosas parecidas, pero distintas!
Para instalar una aplicación…
Solo en Eclipse 3.5
– Ejecutar al menos una vez con
Run > Run As > Java Application
– Pinchar
File > Export > Java > Runnable Jar > Next
Seleccionar…
1. configuración de arranque
La opción con el nombre del programa y del proyecto!
2. Archivo para guardar el código
•En la carpeta elegida queda un archivo .jar
•Si java está instalado, para arrancar la aplicación: Clicar y ya está
En las aplicaciones de escritorio…
Las instrucciones System.out…
– No producen ningún efecto
Es una forma de trabajo obsoleta
– Puede ser todavía una opción razonable para empezar
Instalación de librerías
Para que Eclipse compile y ejecute algunos
programas, debe ser configurado:
– Hay que instalar algunas librerías
Librerías: programas que facilitan algunas tareas
Crea una carpeta:
– puedes elegir el nombre:
java_lib, local_lib…: como prefieras
Descarga los archivos bin.zip y img.zip
– Consulta cómo descargar el archivo img.zip
Copia los archivos en la carpeta
– Sin descomprimir!
Comprobar contenido
Importante!
La carpeta local_lib? contiene esos archivos
Configuración de Eclipse
Pincha Window > Preferences
Despliega
java > Build Path > Classpath Vars
Pincha New
Definir variable
1
Escribir ese
2
nombre!
En mayúsculas!
LOCAL_LIB
Pinchar!
•
Buscar y seleccionar la
carpeta
local_lib?
Comprobar!
4
La que tiene
3
Comprobar variable
Si no es la ruta de la carpeta,
remove y volver atrás
Bien? pulsar OK
Eclipse configurado
Hay que configurar LOCAL_LIB si se
cambia el workspace
Ahora vamos a crear un proyecto
– Para desarrollar una aplicación debes crear
un proyecto…
Completar configuración del
proyecto
Si decides crear más proyectos, debes
seguir las instrucciones siguientes
para cada uno de ellos
El nombre del
proyecto debe estar
seleccionado
Pincha en:
Project > Properties
Propiedades del proyecto…
Selecciona esa
opción y…
Propiedades: java build path
pincha en
Libraries…
Propiedades: Libraries
pincha en
Add Variable…
1
Seleccionar
LOCAL_LIB y
•Seleccionar esos
archivos
•Pinchar con tecla de
control pulsada
3
2
Comprobación
Si no está conforme
1. Seleccionar
2. Remove
3. Volver al paso anterior
No quitar esta nunca
Si todo bien, ok
Comprobar el proyecto
•
•
Ahí ves la versión de java seleccionada y las
librerías utilizables
Si no está así tendremos problemas
Para arreglarlo
1. Seleccionar Project > Properties
2. Build Path
3. Libraries
Y corregir
Lectura y escritura
1.
2.
Crear un nuevo programa: UsoDeIODialog
Para
–
–
pedir datos al usuario
presentar resultados
crear una ventana de diálogo
crear una ventana de diálogo
Primera instrucción:
IODialog entradaSalida = new IODialog();
Crear una ventana de diálogo
Corregir con Eclipse
1. Pinchar en la marca de error
2. En el menú desplegado, seleccionar
Uso de una ventana de diálogo
Para pedir datos
int edad = entradaSalida.readInt("Dime tu edad");
entradaSalida.print("Que...");
entradaSalida.println("viejo eres!");
Y para presentar resultados
Ejecución
Ese botón permanece encendido mientras el programa está en ejecución
Pinchar ahí para abortar
¿Qué archivos crea Eclipse?
En la carpeta del workspace, cada
proyecto, su carpeta
•En src están los textos java
•En bin están los programas traducidos a
lenguaje máquina
En cada
proyecto
¿Qué archivos crea Eclipse?
En el mismo proyecto
puede haber varios
programas
– Los programas se
consideran agrupados en
paquetes
– El nombre de los paquetes
se traduce en carpetas y
subcarpetas
No modificar nunca a mano…
carpetas y archivos creados por Eclipse
en el workspace
•En la ventana Package
Explorer pincha Botón
derecho
•Y selecciona lo que
quieres hacer
•Borrar, cambiar
nombre…
Para llevarte el trabajo a otro
equipo
No copies la carpeta
con el workspace
Pincha en
File > Export > General
Archive File
Y next
Pincha Select All…
zip con los archivos de
los proyectos
Pincha Finish
Para recuperar/cargar proyectos…
El zip con los
proyectos puede
copiarse a otro equipo
Para cargarlos en el
otro equipo
File > Import > General
Selecciona Existing Projects into Workspace y Finish
Selecciona el zip con los proyectos
Pincha Browse para
seleccionar el zip
Select all y finish
•No intentes cargar en tu workspace proyectos que ya tenías
•Es mejor que primero los borres por completo de tu workspace
Para borrar proyectos…
Pincha en el nombre del
proyecto
Botón derecho y Delete
also
Descargar

instrucciones de uso de Eclipse