FUNCIONES DE BÚSQUEDA Y REFERENCIA I
Este tipo de funciones sirven, fundamentalmente, para buscar información
específica en tablas y conseguir otro tipo de información.
ELEGIR: Esta función permite seleccionar un valor de una lista, es decir,
proporcionado un número entero esta función devuelve el enésimo
término de esa lista .
Sintaxis: ELEGIR(núm_índice; valor1; valor2;…)
Campos:
Núm_índice: determina qué valor se devuelve de la lista. Así, si este campo es 1 la
función devolverá valor1, si es 2 devolverá valor2 y así sucesivamente. Este argumento
debe ser un número comprendido entre 1 y 29, o bien una fórmula o referencia a una
celda que contenga un número entre 1 y 29. Cuando este campo es menor que 1 o
mayor que el número del último valor de la lista, la función devuelve el valor de error
#¡VALOR!. .
Valor1;valor2;…: es la lista de 1 a 29 valores de la cual esta función seleccionará y
devolverá el valor. Estos valores pueden ser números, referencias a celdas, nombres
definidos, fórmulas, funciones o texto.
FUNCIONES DE BÚSQUEDA Y REFERENCIA I
Así, supongamos la siguiente fórmula =ELEGIR(1;”IVA AL 4%”;”IVA AL 7%”;”IVA
AL 16%”), en este caso, cómo el campo núm_índice es 1, la función devuelve la
cadena de texto IVA AL 4% ya que éste es el primer valor de la lista. En el
supuesto de emplear referencias de rangos como valores de la lista, la función
ELEGIR devolverá el rango entero como resultado. Por ejemplo, la siguiente
función =ELEGIR(3;B1:B5;C1:C5;D1:D5) devuelve el rango D1:D5. Esta
circunstancia nos permite realizar operaciones condicionadas en un grupo de
rangos, en el que la condición es el valor buscado a través de la función ELEGIR.
Así, la siguiente fórmula nos devuelve la suma del rango D1:D5:
=SUMA(ELEGIR(3;B1:B5;C1:C5;D1:D5)
Esta función es ideal para acciones de búsqueda en las que existe un número
reducido de valores de datos y tiene una fórmula o función que genera valores
secuenciales de números enteros empezando por el uno. Sin embargo, como
señala Mcfedries (2004,272), esta función también tiene sus inconvenientes:
•Los valores a buscar tienen que ser números enteros positivos.
•El número máximo de valores de datos es 29.
•Sólo se permite un grupo de valores de datos por función.
FUNCIONES DE BÚSQUEDA Y REFERENCIA I
BUSCARV: es una función que busca un valor en la columna o el
siguiente valor más alto inferior al valor buscado en la columna más a la
izquierda de una matriz y devuelve el valor en la misma fila de una
columna especificada en la tabla. Esta función se debe emplear cuando
los valores de comparación se encuentren en una columna situada a la
izquierda de los datos que desea encontrar.
Sintaxis: BUSCARV(valor_buscado; matriz_buscar_en;
indicador_columnas;ordenado)
Campos:
Valor_buscado: es el valor buscado en la primera columna de la matriz y puede ser un
valor, referencia o una cadena de texto.
Matriz_buscar_en: es la matriz de datos donde la función busca el valor de referencia
y devuelve el valor buscado, puede ser la referencia a un rango o el nombre de un
rango.
FUNCIONES DE BÚSQUEDA Y REFERENCIA I
Campos:
Indicador_columnas: es el número de la columna de la matriz donde se escogerá el
valor situado en la misma fila que el valor de referencia (valor_buscado). El valor
hallado es el que tomará la función como resultado.
Ordenado: es un valor lógico que especifica si la función debe localizar una
coincidencia exacta o aproximada. Si se omite o es VERDADERO, devolverá una
coincidencia aproximada, es decir, si no localiza ninguna coincidencia exacta, devolverá
el siguiente valor más alto inferior al valor buscado (si el argumento ordenado es
VERDADERO, los valores de la 1ª columna del argumento matriz_buscar_en deben
colocarse en orden ascendente, en caso contrario puede dar un resultado erróneo). Si
es FALSO, la función encontrará una coincidencia exacta. Si no encuentra ninguna,
devolverá el valor de error #N/A.
A tener en cuenta: la función BUSCARH, que opera de la misma forma
que ésta, se utiliza cuando los campos de la matriz de datos están
ordenados por filas en vez de por columnas.
FUNCIONES DE BÚSQUEDA Y REFERENCIA I
Ejemplo:
Supongamos, como ejemplo ilustrativo de esta función, que una empresa quiere
automatizar la emisión de facturas de forma que introduciendo en el rango A14:A19 de
la siguiente figura las referencias de los productos que vende, recogidos en la tabla con
el nombre de Monitores y cuyo rango es A24:D29, rellene automáticamente el concepto,
la base imponible y el tipo de IVA que se aplica después de buscarlo en la tabla.
FUNCIONES DE BÚSQUEDA Y REFERENCIA I
Ejemplo:
•B14: =BUSCARV(A14;Monitores;2;FALSO). Mediante esta función le
estamos ordenando a la hoja que busque el valor introducido en la celda A14
en la tabla denominada Monitores y que si encuentra la coincidencia exacta
seleccione el valor correspondiente de la columna 2 (Artículo). No obstante,
esta fórmula devuelve en la ceda B14 el valor de error #N/A cuando están
vacías las celdas A14:A19. Para solucionarlo, deberíamos anidar esta función
dentro
de
una
función
SI,
es
decir,
=SI(A14<>””;BUSCARV(A14;Monitores;2;FALSO);””). Esta función le indica a
la hoja de cálculo que si la celda A14 no está vacía utilice la función BUSCARV
y que, en caso contrario, no haga nada.
•F14: =SI(A14<>””;BUSCARV(A14;Monitores;3;FALSO);””).
•G14: =SI(A14<>””;BUSCARV(A14;Monitores;4;FALSO);””).
FUNCIONES DE BÚSQUEDA Y REFERENCIA I
Ejemplo:
FUNCIONES DE BÚSQUEDA Y REFERENCIA I
El método básico de búsqueda, esto es, buscar un valor en una
columna o en una fila y devolver otro valor, puede que sea todo lo que
requiera. No obstante, podemos encontrarnos con operaciones que
necesiten una resolución más compleja. Para ello, Excel nos
proporciona funciones de búsqueda más avanzada, la mayoría de las
cuales emplean dos o más funciones de búsqueda.
Por otro lado, uno de los mayores inconvenientes de la función
BUSCARV es que tiene que emplear la columna situada a la izquierda
de la tabla como columna de búsqueda. La función BUSCARH presenta
el mismo problema ya que debe utilizar la fila superior de la tabla como
fila de búsqueda. Para solucionar esta dificultad, así como la descrita
en el párrafo anterior, podemos usar la combinación de dos funciones:
COINCIDIR e INDICE. Funciones que describiremos en la próxima
sesión.
Descargar

Presentación Power Point tercera práctica de laboratorio.