ESTRUCTURAS DE CONTROL
REPETITIVAS
INTEGRANTES
Bernardino Niño
Diana Marcela
Juan David Marín
Julio Cesar Rodríguez
Miguel Pérez Jones
Miguel Ángel Suarez
Milton Javier Villamizar
ESTRUCTURAS DE CONTROL
REPETITIVAS
Son aquellas en las que una sentencia o grupo
de sentencias se repiten muchas veces. Este
conjunto de sentencias se llama Bucle (Lazo o
ciclo).
BUCLE: Es una estructura de control que
permite la repetición de una serie determinada
de sentencias.
ESTRUCTURAS DE CONTROL
REPETITIVAS
Justificación:
50+10+200 = 260
(7531*16)/3 = 40165.333
ESTRUCTURAS DE CONTROL
REPETITIVAS
El cuerpo del bucle contiene las sentencias que se
repiten.
Pascal proporciona tres estructuras de control para
especificar la repetición.
a) Estructura de control while
b) Estructura de control repeat
c) Estructura de control for
ESTRUCTURAS DE CONTROL
REPETITIVAS
Ejemplo: Leer una lista de números desde el teclado y sumar sus valores.
suma := 0;
read (Numero);
Suma : = suma + Numero;
ITERACIÓN.
}
BUCLE
1
read (Numero);
suma : = suma + Numero;
2
read (Nuero);
suma : = suma + Numero;
3
. . .
}
CUERPO
DEL
BUCLE
Tales acciones repetidas se llaman bucles. La acción o acciones que se
repiten en un bucle se denominan cuerpo del bucle, y cada repetición del
cuerpo del bucle se denomina iteración.
1. LA SENTENCIA WHILE
La estructura repetitiva while (mientras) es
aquella en la que el número de instrucciones
no se conoce por anticipado y el cuerpo del
bucle se repite (mientras) se cumpla una
determinada condición.
1. LA SENTENCIA WHILE
mientras condición hacer
while expresión lógica do
sentencia/s
begin
fin mientras
sentencia1
Condición: Expresión
lógica o relacional
.
.
.
}
cuerpo del bucle
I := 1
Sentencia n
mientras I <= 5 hacer
End;
CONDICIÓN
verdadera
Sentencia/s
I := I + 1
Sentencia compuesta
while expresión lógica do
fin_mientras
sentencia;
Sentencia simple
falsa
SENTECIA/S
2. SENTENCIA WHILE
Ejemplo: Imprimir promedio de 50 números.
Inicio
I := 1
AC := 0
mientras I <= 50 hacer
leer N
AC := AC + N
fin_mientras
P := AC/50
Imprimir P
fin
2. SENTENCIA REPEAT
La sentencia repeat específica un bucle
condicional que se repite hasta que la
condición se hace verdadera se denomina
bucle repeat-until.
2. SENTENCIA REPEAT
repetir
Sentencias
Cuerpo del
bucle
<
sentencias>
hasta_que condición
Condición expresión lógica o relacional
repetir
falsa
verdadera
Sentencias
CONDICION
I := I +1
Fin_hasta
Después de cada interacción el cuerpo del bucle evalúa la
condición. Si la condición es verdadera (true), el bucle se
termina y se sale de el, ejecutándose la siguiente sentencia. Si
la condición es falsa (false) el cuerpo del bucle se repite.
2. SENTENCIA REPEAT
sentencias
repeat
unitil
;
repeat
Sentencias 1
.
.
.
Sentencia n
Until expresión lógica
Cuerpo
del bucle
expresión
1. LA SENTENCIA REPEAT
Ejemplo: Imprimir promedio de 50 números.
inicio
AC := 0
I := 1
Repita
leer N
AC := AC + N
I := I+1
Hasta I = 50
P := AC/50
Imprimir P
fin
3. SENTENCIA FOR
Desde i ← valor inicial hasta valor final hacer
Sentencias
fin_desde
for variable:= valor inicial to valor final do
Sentencia;
for I := 1 to 3 do
Sentencias;
La sentencia for requiere que conozcamos
por anticipado el numero de veces que se
ejecutan las sentencias del interior del bucle.
3. SENTENCIA FOR
for
variable
;
Expresión
to
Expresión
do
sentencia
La variable v se denomina variable de control del bucle.
Cuando se ejecuta la sentencia for, a la variable v se le
asigna el valor inicial; al llegar a la sentencia end se
verifica si el valor final es mayor que el valor inicial; en
caso negativo se incrementa el valor de la variable de
control en uno y se vuelven a ejecutar todas la
sentencias del interior del bucle, hasta que la variable de
control sea mayor que el valor final, en cuyo momento
se termina el bucle.
1. LA SENTENCIA FOR
Ejemplo: Imprimir promedio de 50 números.
inicio
AC := 0
para I:= 1 hasta 50 hacer
leer N
AC := AC + N
fin_para
P := AC/50
Imprimir P
fin
ESTRUCTURAS DE CONTROL REPETITIVAS
Glosario:
1. Acumulador := 0
Aumenta en los valores de las variables que se lean.
2. Contador := 1
Incrementa el ciclo en el intervalo que se defina.
3. Variable:
Son objetos de un programa cuyo valor pude variar
durante la ejecución del programa.
4. Constante:
Es un valor que no puede cambiar durante la ejecución
del programa.
ESTRUCTURAS DE CONTROL REPETITIVAS
Glosario:
5. Sentencias: Describen las acciones algorítmicas que
pueden ser ejecutadas.
6. Algoritmo: Es un método para resolver un problema
mediante una serie de pasos, definidos y finitos.
Características de un Algoritmo:
• Preciso: (Indicar el orden de realización en cada paso).
• Definido: (Si se sigue dos veces, obtiene el mismo
resultado
cada vez)
• Finito: (Tiene fin; un nuero determinado de pasos)
ESTRUCTURAS DE CONTROL REPETITIVAS
Glosario:
Nota: Los algoritmos se pueden expresar por formulas,
diagramas
de flujo y pseudocódigo.
7. Diagrama de flujo (flowchart):
Es una representación grafica de un algoritmo.
8. Pseudocódigo:
Lenguaje de especificaciones de algoritmos, escrito en
ingles o español.
Muchas gracias
Descargar

Diapositiva 1