Publicación de bases de datos Access
en la web
Publicación en Internet con Microsoft Office
Sevilla, junio de 2004
Salir
Iniciar
Access
Publicación de bases de datos Access
en la web
Introducción
Creación de documentos HTML con Access
Los archivos de plantilla HTML
Hipervínculos en Access
Salir
Access
Introducción



Salir
Access puede utilizarse para publicar páginas
web que muestren información de una base de
datos
y para crear formularios para que el usuario
pueda solicitar, modificar y enviar la
información a la base de datos
Es necesario tener instalados los componentes
de Office Creación de páginas HTML y Convertir
HTML
Menú
Access
Creación de documentos HTML con Access



Salir
Los objetos principales de las bases de datos
Access (tablas, consultas, formularios e
informes) pueden ser exportados a formato
HTML
Cada objeto exportado crea una página web,
excepto los informes, que crean tantas como
páginas tenga el informe
Los objetos pueden exportarse individualmente
con o sin asistente, pero si se exportan varios a
la vez hay que usar el asistente
Menú
Access
Creación de documentos HTML con Access

Salir
Se puede publicar un objeto de una base de
datos Access en dos formatos:
 HTML estático: aunque se modifiquen los
datos originales de la base de datos, no se
ven las modificaciones en las páginas web
 HTML dinámico: los cambios en la base
de datos se reflejan automáticamente en las
páginas web; el servidor web debe tener
instalado un controlador ODBC para los
archivos de base de datos Access
Menú
Access
Creación de documentos HTML con Access


Salir
Las tablas, consultas y formularios se pueden
convertir a formato estático o dinámico, pero
los informes sólo se pueden convertir a formato
estático
Los datos de los formularios en formato
dinámico pueden ser mostrados tanto en Vista
Hoja de datos como en Vista Formulario, pero en
formato estático sólo puede mostrarse en Vista
Hoja de datos
Menú
Access
Creación de páginas web con formato
HTML estático con asistente
1 abrir la base de datos
y seleccionar Archivo >
Guardar como HTML
2 en el primer cuadro
del asistente hacer
clic en Siguiente
3 seleccionar los objetos a
publicar (si se desea
publicar más de un tipo de
objetos debe hacerse desde
la ficha Todos los objetos)
Salir
Menú
Access
Creación de páginas web con formato
HTML estático con asistente
4 seleccionar, si se desea,
una plantilla HTML para
las páginas generadas
5 indicar si se quieren
plantillas diferentes para
algunos objetos; en tal
caso, hacer clic en
Siguiente y escoger las
plantillas para los objetos
Salir
Menú
Access
Creación de páginas web con formato
HTML estático con asistente
6 escoger el formato
HTML estático
7 en el siguiente
cuadro seleccionar la
carpeta donde guardar
los ficheros generados
8 el asistente permite crear una página principal
que vincula a todos los elementos creados, y
crear un perfil de publicación web para que sea
más fácil y rápido volver a publicarlas
Salir
Menú
Access
Creación de páginas web con formato
HTML estático sin asistente
1 abrir la tabla, consulta o
formulario que se desee
exportar y seleccionar Archivo
> Guardar como o exportar
2 en el cuadro Guardar
como seleccionar la opción
En un archivo o una base de
datos externos
3 indicar la carpeta de
destino y la opción Guardar
como tipo: Documento HTML
Salir
Menú
Access
Creación de páginas web con formato
HTML estático sin asistente
4 en el mismo cuadro, seleccionar las
opciones Guardar con formato y Autoinicio para
que la tabla exportada presente un formato lo
más parecido posible al de la hoja de datos
original, y se muestre automáticamente al
finalizar ; hacer clic en Exportar
5 en el cuadro Opciones de salida hacia HTML
indicar la ruta de acceso hacia la plantilla a
utilizar, y al pulsar en Aceptar la página web
generada se mostrará en el navegador
Salir
Menú
Access
Creación de páginas web con formato
HTML dinámico con asistente
1 realizar los tres primeros pasos
señalados en el formato estático
2 en el siguiente
paso, elegir la opción
ASP dinámico (el
servidor debe tener el
componente Páginas
Active Server)
Salir
Menú
Access
Creación de páginas web con formato
HTML dinámico con asistente
3 rellenar los datos del origen de
los datos y la dirección URL
donde se almacenarán los archivos
script de las páginas web
4 las demás
ventanas son las
mismas que con
formato estático
Salir
Menú
Access
Creación de páginas web con formato
HTML dinámico sin asistente
Los pasos son los mismos que en formato
estático, pero en el cuadro de diálogo Guardar
como, en el cuadro de lista Guardar como tipo, se
debe seleccionar los archivos con extensión .asp
(o .htx e .idc si se desea el formato dinámico IIS)
Al hacer clic en Exportar, se muestra el
cuadro de diálogo de la diapositiva
anterior ; rellenar los datos como se
indicó y la página web dinámica se habrá
guardado en la carpeta especificada
Salir
Menú
Access
Los archivos de plantilla HTML



Salir
Las plantillas son útiles para mejorar la
presentación de los datos en las páginas web
Los ficheros gráficos .jpg correspondientes a
las plantillas deben almacenarse en la misma
carpeta que los archivos generardos
Los archivos de plantilla personalizada, que
pueden crearse usando los recursos aprendidos
en Word, deben tener la extensión .htm
Menú
Access
Hipervínculos en Access



Salir
En Access se pueden insertar hipervínculos
en los campos de las tablas o en los controles
de los formularios e informes para compartir
la información almacenada en otra posición
Para crear un hipervínculo hay que tener un
campo para tal fin en una tabla
Una vez creado el campo, se podrá crear el
hipervínculo en cualquier objeto de Access:
tablas, consultas, formularios e informes
Menú
Access
Crear un campo de hipervínculo
Para crear un campo de hipervínculos en la
vista Diseño:
1 abrir la base de datos y
seleccionar la tabla en la que se
quiera crear un hipervínculo;
hacer clic en el botón Diseño
2 escribir el Nombre del campo
y escoger Hipervínculo en la
lista desplegable Tipo de datos
3 seleccionar Archivo > Guardar
Salir
Menú
Access
Crear un campo de hipervínculo
Para crear un campo de hipervínculos en la
vista Hoja de datos:
1 abrir la tabla en el
modo vista Hoja de datos
2 situarse en el lugar donde se
desee añadir un campo de hipervínculo y seleccionar Insertar >
Columna de hipervínculo (para
cambiar el nombre del campo
hay que ir a la vista Diseño)
3 seleccionar Archivo > Guardar
Salir
Menú
Access
Insertar un hipervínculo en un campo de
hipervínculo



Salir
Diseñar una consulta con hipervínculos es
fácil: basta con seleccionar el campo o los
campos donde se encuentren
Los informes con hipervínculos son similares
a los formularios en el modo de vista
Formulario
Veamos los detalles de inserción de
hipervínculos en tablas y formularios
Menú
Access
Crear hipervínculos en tablas
1 abrir la tabla con el campo de
hipervínculos en vista Hoja de datos
2 situarse en el registro donde se quiere insertar
el hipervínculo, dentro del campo diseñado para
ello y seleccionar Insertar > Hipervínculo
3 indicar en el cuadro Vincular al archivo
o dirección URL la ruta del enlace
4 rellenar el cuadro Ubicación dentro del archivo si
se desea enlazar a un objeto de la base de datos
Salir
Menú
Access
Crear hipervínculos en tablas
Otros métodos para crear hipervínculos
en una tabla:
 escribiendo
directamente el archivo
o dirección URL en la celda de la
hoja de datos en la que se quiere que
aparezca el hipervínculo
 trayendo
el hipervínculo de otro lugar,
mediante Cortar, Copiar y Pegar, o
arrastrándolo con el ratón
Salir
Menú
Access
Crear hipervínculos en formularios e
informes
En los formularios se pueden asociar etiquetas,
botones de acción e imágenes a los hipervínculos
Para crear etiquetas:
1 abrir el formulario en vista Diseño
2 situarse donde se desee insertar la etiqueta para
el hipervínculo y seleccionar Insertar > Hipervínculo
3 en el cuadro de diálogo Insertar hipervínculo
seguir el proceso señalado anteriormente
Salir
Menú
Access
Crear hipervínculos en formularios e
informes
Para crear botones de acción o imágenes se debe
usar el Cuadro de herramientas
1 abrir el formulario
en vista Diseño
2 hacer clic en la
herramienta Botón de
comando o Imagen en el
Cuadro de herramientas
Salir
Menú
Access
Crear hipervínculos en formularios e
informes
3 hacer clic en el lugar
de la sección Detalle
donde se desee situar el
botón o la imagen y
darle el tamaño deseado
arrastrando el ratón
4 indicar la Dirección de hipervínculo en
el menú Propiedades (pulsar botón
derecho del ratón sobre el control)
Salir
Menú
Access
Editar hipervínculos


Salir
Se pueden editar los hipervínculos creados
aplicando las tareas de edición típicas: cortar,
copiar, pegar, modificar y eliminar
Para copiar un hipervínculo, seleccionar el
enlace y luego efectuar las operaciones
Edición > Copiar y Edición > Pegar (en el lugar
deseado)
Menú
Access
Modificar hipervínculos
Para modificar el formato predeterminado de los
hipervínculos:
1 abrir la base de datos y
seleccionar Herramientas >
Opciones
2 seleccionar la ficha
Hipervínculos/HTML
3 establecer las
opciones deseadas y
hacer clic en Aceptar
Salir
Menú
Access
Modificar hipervínculos
Para modificar un hipervínculo:
1 abrir el objeto de Access que
contenga el hipervínculo
2 seleccionar el hipervínculo haciendo
clic con el botón derecho del ratón
3a seleccionar Hipervínculo > Modificar hipervínculo
(el cuadro que aparece, Modificar hipervínculo, es
similar a Insertar hipervínculo, visto antes)
3b seleccionar Hipervínculo > Mostrar texto para
modificar el texto del hipervínculo
Salir
Menú
Access
Eliminar hipervínculos
Para eliminar un hipervínculo creado en una tabla,
en una consulta o en un formulario dependiente de
una tabla que contenga el hipervínculo:
1 abrir el objeto de Access que
contenga el hipervínculo
2 situarse en el registro que contenga
el hipervínculo y hacer clic con el
botón derecho del ratón
3 seleccionar Hipervínculo > Modificar hipervínculo
y hacer clic en Quitar vínculo
Salir
Menú
Access
Eliminar hipervínculos
Para eliminar todos los hipervínculos creados en
una tabla:
1 eliminar el campo Hipervínculo de vista Diseño
de la tabla
Para eliminar un hipervínculo creado en vista
Diseño de un formulario:
1 abrir el formulario en vista Diseño
2 seleccionar el hipervínculo y pulsar <Supr>
Salir
Menú
Descargar

Publicación de bases de datos Access en la Web