Creación de páginas web con Word
Publicación en Internet con Microsoft Office
Sevilla, junio de 2004
Salir
Iniciar
Word
Creación de páginas web con Word
Introducción
Métodos de creación de páginas web con Word
Cómo dar formato a páginas web
Imágenes
Hipervínculos y marcadores
Creación de tablas
Formularios
Inclusión de otros elementos
Salir
Word
Introducción
Word permite, sin necesidad de conocer el
lenguaje HTML:
 crear páginas web para su publicación en
internet
 ... que pueden incorporar hipervínculos y
elementos multimedia como gráficos, sonidos,
vídeos y animaciones
 así como crear formularios para permitir la
comunicación con los visitantes de nuestras
páginas
Salir
Menú
Word
Métodos de creación de páginas web con
Word
Word incluye tres métodos sencillos para crear
páginas web:
 Crear una página web utilizando un asistente o
una plantilla
 Utilizar una página web en blanco, para
diseñar desde el principio el documento
 Convertir cualquier documento de Word, ya
creado, en formato HTML
Salir
Menú
Word
Uso del asistente para páginas web
1 seleccionar Archivo > Nuevo > Páginas web
2 seleccionar Asistente para páginas web
3 seguir los pasos del asistente para definir:
- título y ubicación
- desplazamiento
- agregar/organizar páginas
- tema visual
(moverse con Siguiente/Anterior o haciendo click
en cada elemento del asistente)
4 hacer click en Finalizar
Salir
Menú
Word
Guardar documentos Word en formato HTML
1 seleccionar Archivo > Guardar como página Web...
(o Archivo > Guardar como)
2 especificar ubicación y nombre para el fichero
3 (si en 1 se escogió Guardar como, en la opción
Guardar como tipo, elegir Página Web (*.htm; *html))
4 hacer clic en Guardar
Salir
Menú
Word
Crear una página web a partir de una página
en blanco o plantilla
1 seleccionar Archivo > Nuevo
2 elegir uno de estos dos procedimientos:
2a en la ficha General, escoger Página web para
abrir una página web en blanco
2a
en la ficha Páginas Web, escoger la plantilla
deseada
3 editar el documento
Salir
Menú
Word
Introducción de texto




Salir
El texto sencillo se estructura en párrafos.
Para insertar un nuevo párrafo, se usa <Intro>.
Los navegadores suelen insertar un espacio
adicional entre dos párrafos del texto.
Se puede forzar un salto de línea sin crear un
espacio adicional, pulsando <Mayús-Intro>.
Word no permite insertar tabulaciones dentro
del texto de una página web. Para alinear se
usarán las tablas.
Menú
Word
Asignar un título a una página web

El título aparece en la barra de título del
navegador y es usado para referenciar a la
página web (historial, favoritos...)
1 seleccionar Archivo > Guardar como página Web
2 hacer click en Cambiar título
3 escribir el título deseado en el cuadro Título de la
página, y hacer click en Aceptar
(También en Archivo > Propedades, en el cuadro
Título de la ficha Resumen)
Salir
Menú
Word
Insertar encabezados


Salir
Los encabezados sirven para la estructuración
básica de un documento.
Word dispone de 9 niveles de encabezamientos
diferentes, etiquetados con los nombres Título 1
(H1 en HTML), Título 2 (H2 en HTML), Título 3
(H3 en HTML), etc.
(H1 se corresponde con el nivel más alto, y por
tanto con un tamaño de fuente mayor)
Menú
Word
Insertar encabezados

Para insertar un encabezados en una página web:
1 marcar la palabra o frase que se quiera resaltar
como encabezado
2 seleccionar Formato > Estilo
3 en la ventana de Estilos, seleccionar un
encabezado entre Título 1 y Título 9
4 hacer clic sobre el botón Aplicar
Salir
Menú
Word
Insertar una línea horizontal con diferentes
estilos
1 situarse donde se desee introducir la línea horizontal
2 seleccionar Formato > Bordes y sombreado
3 hacer click en Línea horizontal
4 para ver las propiedades de una línea, hacer click
con el botón derecho y seleccionar Propiedades
5 elegir un estilo de línea y pulsar sobre Aceptar
(para usar una imagen externa, pulsar Importar clips)
6 pulsar con el botón derecho y elegir Dar formato a la
línea horizontal para modificar el formato de la línea
Salir
Menú
Word
Agregar texto desplazable a una página web


Salir
Una marquesina (o línea de desplazamiento de
texto) es un rectángulo fijo en pantalla dentro
del cual se puede incluir texto en movimiento
que se repite de forma continua.
Se usa para destacar alguna información para
el usuario, llamando su atención.
Menú
Word
Agregar texto desplazable a una página web
1 seleccionar Ver > Barra de herramientas y activar
Herramientas Web
2 situar el cursor donde se desee introducir la
marquesina
3 hacer click en el icono Desplazar texto en la barra de
herramientas Web
4 en el cuadro Desplazamiento de texto, indicar el texto
desplazable, y otras propiedades de la marquesina.
5 Hacer click en Aceptar.
Salir
Menú
Word
Crear una plantilla HTML personalizada


Salir
Existe la posibilidad de utilizar el documento
creado como base para hacer otras páginas
web de temática similar
Para ello, se guardará una copia del documento
como una plantilla
Menú
Word
Crear una plantilla HTML personalizada
1 seleccionar Archivo > Guardar como página Web
2 abrir la lista Guardar como tipo y elegir Plantilla
de documento (*.dot)
3 elegir ubicación y nombre de la plantilla
4 hacer clic en Guardar
Salir
Menú
Word
Cómo dar formatos a páginas web



Salir
Se pueden usar la mayoría de herramientas
para dar formato en documentos Word
Word crea automáticamente el código HTML
necesario para el diseño de las páginas
Los formatos no compatibles con HTML no
están disponibles en el entorno de trabajo de
Word para la Web (efectos de sombra y
relieve, interlineado, márgenes, tabulaciones...)
Menú
Word
Cómo dar formatos a páginas web
Existen dos tipos de estilos de formato:
 Formatos de párrafo:
niveles de encabezamiento y opciones de
justificación que afectan a todos los párrafos
del bloque de texto seleccionado
 Formatos de texto:
Tipos de letra, estilos, tamaños y colores
Salir
Menú
Word
Formatos de párrafo
Para aplicar o modificar un estilo de párrafo:
1 situar el punto de inserción en cualquier parte
del párrafo
2 abrir la lista desplegable de Estilo y elegir el
deseado
3 también se puede elegir el estilo a través de
Formato > Estilo
Salir
Menú
Word
Formatos de párrafo
Algunos ejemplos de estilos:
 Dirección: inserta la “firma” de una página
web que indica quién ha hecho la página, la
fecha, avisos de copyright y correo electrónico
 Encabezamientos 1 a 9: dividen secciones de
texto. Niveles en función del tamaño de letra
 Listas: de varios tipos, de viñetas, numeradas...
 Normal: elimina cualquier formato de párrafo
y reinicia el párrafo a su estilo por defecto
Salir
Menú
Word
Formatos de párrafo

Alineación de párrafo
Alinear a
la izquierda

Salir
Centrar
Alinear a
la derecha
Sangrar un párrafo
Permite crear listas y sublistas. En el Editor,
seleccionar el texto a sangrar y hacer clic en los
botones Aumentar sangría
o Disminuir sangría
Menú
Word
Formatos de texto
1 seleccionar el texto
2 seleccionar Formato > Fuente (o métodos
alternativos)
3 cambiar Fuente, tamaño, color y estilo (efectos)
4 algunos parámetros se pueden cambiar
directamente desde la barra de herramientas
Salir
Menú
Word
Definir estilos de formatos
Antes de crear un párrafo, o después si se ha
seleccionado, se puede dar un estilo de formato al
texto mediante el uso de

Viñetas

Listas de numeración
Fondos de color o textura ...

Salir
Menú
Word
Crear listas de viñetas y de numeración

Para ambos tipos de listas:
1 seleccionar Formato > Numeración y viñetas

Para listas de viñetas:
2 abrir la ficha Viñetas
3 elegir uno de los estilos que aparecen en la ventana,
4 o... pulsar en Imagen para elegir una viñeta almacenada en fichero grafico en el disco (*.gif, *.jpg, ...)
5 hacer clic en Aceptar
Salir
Menú
Word
Crear listas de viñetas y de numeración

Para listas de numeración:
2 abrir la ficha Números
3 seleccionar el estilo deseado
4 elegir entre Reiniciar numeración y Continuar lista
anterior
5 hacer clic en Aceptar
Salir
Menú
Word
Crear listas de viñetas y de numeración
La numeración automática
de esquemas y títulos no
está disponible en el
entorno de trabajo de Web
Para conseguir el mismo
efecto que en esquemas
numerados (listas múltiples
a distintos niveles) hay que
aplicar diferentes estilos de
numeración y sangrías
Salir
Menú
Word
Establecer colores de texto

Se puede cambiar el color del texto,
hipervínculos e hipervínculos visitados para
toda la página.
1 marcar el texto (o hipervínculo)
2 seleccionar Formato > Fuente
3 elegir el color de fuente
4 hacer clic en Aceptar
Salir
Menú
Word
Agregar color de fondo y textura
1 seleccionar Formato > Fondo
2 escoger un color de entre los mostrados
3 o hacer clic en Más colores para elegir uno
personalizado
4 se puede escoger Efectos de relleno para insertar
como fondo una textura
5 se puede escoger como textura una imagen
gráfica de archivo en disco (pulsar Otra textura
u Otra imagen)
Salir
Menú
Word
Imágenes



Salir
Aumentan el atractivo visual y el contenido
informativo de las páginas web
Se usan para transmitir información, servir
como zonas activas de hipervínculos, etc.
Debe hacerse un uso adecuado de las mismas,
teniéndose en cuenta, sobre todo, el tamaño de
los archivos utilizados.
Menú
Word
Inserción de una imagen
1 situar el punto de inserción en el lugar deseado
2 seleccionar Insertar > Imagen > Imágenes
prediseñadas
3 elegir la categoría que se desee haciendo click
sobre el icono corresepondiente
4 hacer click sobre la imagen deseada y pulsar el
icono Insertar clip
Salir
Menú
Word
Insertar una imagen desde un archivo
1 situar el punto de inserción en el lugar deseado
2 seleccionar Insertar > Imagen > Desde archivo
3 localizar el archivo de imagen
4 hacer click sobre la imagen deseada y pulsar el
icono Insertar
Salir
Menú
Word
Insertar una imagen desde el portapapeles
1 seleccionar el gráfico o dibujo desde cualquier
programa gráfico
2 seleccionar Edición > Copiar (o pulsar <Ctrl-C>)
para insertar el contenido en el portapapeles
3 colocar el punto de inserción en el lugar
deseado de la página
4 seleccionar Edición > Pegar ( o pulsar <Ctrl-V>)
para insertar el contenido del portapapeles en
la página web
Salir
Menú
Word
Atributos de las imágenes
Se puede modificar el aspecto de las imágenes ya
insertadas en una página web:
 ajustando el texto alrededor del gráfico
 especificando la alineación del gráfico
 definiendo un texto alternativo para
visualizarlo en el navegador
Para ello:
1 seleccionar la imagen haciendo clic
sobre ella
2 seleccionar Formato > Imagen
Salir
Menú
Word
Tamaño de la imagen
Se puede cambiar el tamaño usando
los puntos de control (tiradores):
1 seleccionar la imagen
2 hacer clic sobre el
tirador que se desee y, sin
soltar el ratón, arrastrar en
la dirección deseada
Puntos de control
Salir
Menú
Word
Alineación del texto con la imagen

Para ajustar el texto respecto de la imagen:
1 seleccionar la imagen
2 seleccionar Formato > Imagen
3 abrir la ficha Diseño y escoger el estilo de ajuste
a aplicar. Para tener acceso a más estilos de
ajuste y opciones, hacer click en Avanzado
4 se puede especificar la distancia al texto
(Espacio vertical y Espacio horizontal) en la ficha
Posición de la imagen
5 hacer clic en Aceptar
Salir
Menú
Word
Texto alternativo

A veces, cuando no es posible mostrar la
imagen (o mientras se descarga), el navegador
muestra un texto en lugar alternativo. Para
configurar esta opción:
1 seleccionar la imagen en la que se desea
insertar un texto alternativo
2 seleccionar Formato > Imagen
3 abrir la ficha Web y escribir el texto alternativo
4 hacer clic en Aceptar
Salir
Menú
Word
Formatos gráficos
Los dos formatos de gráficos más frecuentes en
los navegadores web son:
 GIF: imágenes de hasta 8 bits de color (hasta
256 colores). Permite transparencia y
entrelazado. Se usa para imágenes pequeñas o
dibujos que no sobrepasen los 256 colores
 JPEG (JPG): soporta imágenes de 24 bits de
color (16,7 millones de colores). Se debe usar
para fotografías e imágenes con amplia gama
de colores
Salir
Menú
Word
Tipos especiales de imágenes


Salir
Imágenes transparentes: el formato GIF
permite especificar uno de los colores de la
paleta como color transparente
Imágenes animadas: el formato GIF permite
almacenar varias imágenes en un mismo fichero,
de manera que al visualizarlas en el navegador
aparecen sucesivamente superponiéndose a la
imagen anterior (GIF animados)
Menú
Word
Tipos especiales de imágenes


Salir
Imágenes entrelazadas: permiten acelerar su
visualización, ya que las líneas de la imagen no
se graban consecutivamente, sino de forma
entrelazada. Al dibujarse la imagen no se hace
de arriba a abajo, sino por bandas.
Imágenes de baja resolución: en HTML se
puede indicar que se cargue una imagen de baja
resolución mientras llega la imagen buena.
Menú
Word
Imágenes de fondo




Salir
Como ya se vio, se puede poner una imagen
como fondo de la página web, a través de
Formato > Fondo > Efectos de relleno > Otra textura.
La imagen se coloca formando un mosaico hasta
completar la ventana donde se muestra la página
Ejemplos típicos: textura, línea bicolor, logotipo
Para no entorpecer la visualización global de la
página, debe considerarse el contraste con el
color del texto
Menú
Word
Aplicaciones de las imágenes



Salir
Fila de imágenes: muy usada para barras de
navegación (grupo de imágenes alineadas usadas
como enlaces)
Iconos: existen bibliotecas de iconos con gran
variedad de gráficos de uso frecuente (fondos,
líneas, botones, logos...)
Formateado de párrafos: puede usarse una
imagen transparente (gif de 1 pixel x 1 pixel)
controlando su tamaño para añadir espaciados
horizontales y verticales
Menú
Word
Gestión eficiente de imágenes
Los siguientes aspectos pueden mejorar la carga de
las imágenes:
 Utilizar imágenes entrelazadas
 Especificar el tamaño de la imagen
 Incluir versiones reducidas de las imágenes
(iconos) que enlacen con las versiones completas
 Reescalar la imagen al tamaño deseado
 Disminuir el número de colores
 La suma de los tamaños de las imágenes no debe
ser muy grande
Salir
Menú
Word
Hipervínculos y marcadores


Salir
Un hipervínculo es un enlace que puede hacer
saltar a una ubicación dentro del documento de
la página web activa, a otra página web o a un
archivo creado en otro programa
Para crear hipervínculos en Office es necesario
tener activada la opción Rutas de red e Internet
por hipervínculos en el menú Herramientas >
Autocorrección > Autoformato
Menú
Word
Creación de hipervínculos
1 resaltar el texto o seleccionar la imagen que se desee
presentar como hipervínculo
2 seleccionar Insertar > Hipervínculo (o hacer clic en
3 en el cuadro Insertar hipervínculo, escribir la ruta de
)
acceso o hacer clic en Archivo... para seleccionar de
una lista de archivos
4 o especificar el nombre del marcador en Marcador...
si se desea un salto dentro del documento
5 o una cuenta de correo en Dir. de correo electrónico
6 hacer clic en Aceptar
Salir
Menú
Word
Editar hipervínculos

Para cambiar el texto o la imagen de un
hipervínculo:
1 seleccionar con el teclado para evitar “seguir”
el hipervínculo (mantener pulsada la tecla
<Mayús> mientras se desplaza con los
cursores)
2 modificar la imagen o texto insertando el nuevo
Salir
Menú
Word
Editar hipervínculos

Para cambiar el aspecto de todos los
hipervínculos del documento:
1 abrir el documento
2 seleccionar Formato > Estilo
3 en el cuadro Estilos, hacer clic en Hipervínculo o
Hipervínculo visitado, y elegir la opción Modificar
4 para cambiar la fuente, el estilo y el tamaño de
la fuente y el color del hipervínculo, elegir
Formato > Fuente
5 seleccionar las opciones deseadas
Salir
Menú
Word
Editar hipervínculos

Para copiar, modificar o realizar otras
operaciones sobre un hipervínculo:
1 pulsar el botón derecho del ratón para abrir el
menú contextual
2 seleccionar la opción Hipervínculo
3 hacer clic en Modificar hipervínculo y seleccionar
las opciones deseadas

Para eliminar un hipervínculo:
1 en el menú Modificar hipervínculo, hacer clic en
Quitar vínculo
Salir
Menú
Word
Marcadores

Los marcadores (anclajes) son los puntos de
los documentos a los que se asocian los
hipervínculos. Para crear un marcador:
1 situarse con el ratón en la posición de destino
del hipervínculo
2 seleccionar Insertar > Marcador y dar un nombre
al marcador. Hacer clic en Agregar
Salir
Menú
Word
Marcadores

Para eliminar un marcador
(y su hipervínculo):
1 seleccionar Insertar > Marcador y escoger el
nombre del marcador.
2 hacer click en el botón Eliminar
3 hacer click en Aceptar
Salir
Menú
Word
Creación de tablas




Salir
Las tablas permiten organizar la información
en filas y columnas
Sin tablas es muy difícil mantener la
alineación de texto y gráficos en HTML
Cada celda puede contener información de
distinto tipo, asín como tener distinto formato
El uso en el entorno de trabajo web es muy
similar al de documentos Word normales
Menú
Word
Insertar una tabla
1 situar la posición de inserción en el lugar
deseado
2 seleccionar Tabla > Insertar tabla
3 en el cuadro Insertar tabla, seleccionar el
número de filas y de columnas
4 para que las líneas de división sean visibles,
activar la opción Tabla > Mostrar líneas de
división
Salir
Menú
Word
Seleccionar y eliminar tablas

Para seleccionar una tabla:
1 hacer clic en cualquier parte de la tabla
2 seleccionar Tabla > Seleccionar tabla

Para eliminar una tabla:
3 una vez seleccionada la tabla, seleccionar
Edición > Borrar (o pulsar <Supr>)
Salir
Menú
Word
Añadir filas y columnas

Para añadir una nueva fila por encima de
otra:
1 hacer clic en cualquier celda de la fila
2 seleccionar Tabla > Insertar filas

Para añadir una nueva columna a la
izquierda de otra:
1 hacer clic en cualquier celda de la columna y
seleccionar Tabla > Seleccionar columna
2 seleccionar Tabla > Insertar columnas
Salir
Menú
Word
Eliminar filas, columnas y celdas

Para borrar una fila:
1 hacer clic en cualquier celda de la fila y
seleccionar Tabla > Seleccionar fila
2 seleccionar Tabla > Eliminar filas


Las columnas se borran de manera similar
Para borra una celda:
1 hacer clic en la celda
2 seleccionar Tabla > Eliminar celdas
3 elegir la forma de reagrupar las demás celdas
Salir
Menú
Word
Combinar y dividir celdas

Para combinar varias celdas:
1 seleccionar dos o más celdas que se desee unir
2 seleccionar Tabla > Combinar celdas

Para dividir una celda en varias:
1 hacer clic en la celda que se desee dividir
2 seleccionar Tabla > Dividir celdas
3 seleccionar el número de filas y de columnas en
las que se desea dividir la celda
Salir
Menú
Word
Establecer las propiedades de las tablas
Para modificar el aspecto de las tablas se pueden
usar distintas opciones, agrupadas en el menú
Propiedades de tabla según a qué elementos afectan:
 Propiedades de tabla
 Propiedades de celda
 Bordes, en la ficha Tabla
Salir
Menú
Word
Establecer las propiedades de las tablas

Para modificar los aspectos comunes a toda la
tabla:
1 situar el punto de inserción en cualquier lugar de la
tabla y seleccionar Tabla > Propiedades de tabla
2 en la ficha Tabla, modificar las opciones deseadas
(alineación, ajuste de texto), y en Opciones
(márgenes y espaciado entre celdas)
Salir
Menú
Word
Establecer las propiedades de las tablas

Para modificar el formato de celdas
individuales:
1 situar el punto de inserción en la celda y
seleccionar Tabla > Propiedades de tabla > Celda
2 modificar las opciones deseadas: alineación
vertical y tamaño. (También puede cambiarse el
tamaño pasando el ratón por las líneas de
separación y ajustándolas )
Salir
Menú
Word
Establecer las propiedades de las tablas




Salir
Las tablas incluyen bordes sencillos al insertarlas
en Word.
Es posible diseñar bordes y sombreado para
celdas aisladas.
Para ello, seleccionar Bordes y sombreado desde
Formato o Tabla > Propiedades de tabla, y establecer
las propiedades de bordes o sombreado (fondo de
celda).
En la opción Aplicar indicar si los cambios afectan
a la celda (o grupo de celdas) o a la tabla
Menú
Word
Convertir texto en tabla
1 seleccionar el texto que se desee convertir en tabla
2 seleccionar Tabla > Convertir texto en tabla
3 especificar el número de filas y columnas y el
separador de las partes del texto
4 hacer clic en Autoformato si se desea usar un
formato de tabla predefinido en Word
Salir
Menú
Word
Dividir una tabla

Una vez creada una tabla, puede dividirse en dos
para modificar su aspecto:
1 situar el punto de inserción en una celda de la fila
inferior de la separación y seleccionar Tabla >
Dividir tabla
2 para restaurar la tabla, pulsar <Supr> en la línea
de separación originada
Salir
Menú
Word
Formularios



Salir
Los formularios permiten el envío de información desde el cliente hacia el servidor web
Un formulario consta de una serie de controles
(cuadros de texto, botones de opciones, menús
de lista desplegables...) para recoger distintos
tipos de información
Los formularios necesitan la ejecución de programas o scripts por medio del CGI (Common
Gateway Interface) para procesar la información
y producir unos resultados hacia el cliente
Menú
Word
Formularios
Usos típicos de los formularios:






Salir
Realizar búsquedas en bases de datos
Rellenar cuestionarios
Solicitar información sobre un tema
Inscribirse en una lista de distribución
Crear un libro de firmas
Colocar un contador de visitas a la página
Menú
Word
Crear un formulario a partir de una página
web en blanco


Salir
Word permite crear un formulario a partir de una
página en blanco, o añadirlo como parte de una
página que se esté diseñando
La estructura del formulario es:
 Etiqueta de inicio del formulario
 Cuerpo del formulario, conteniendo los
controles para la introducción de datos
 Botones de envío y restablecer
 Etiqueta de cierre del formulario
Menú
Word
Tipos de controles de formularios
Salir
Menú
Word
Tipos de controles de formularios



Salir
Casilla de verificación: permite seleccionar
valores lógicos (sí / no)
Botones de opción (o de radio): permite
seleccionar una opción entre varias asociadas a
un mismo grupo
Cuadros de lista (desplegable): presentan una
serie de elementos para seleccionar (de un
cuadro desplegable)
Menú
Word
Tipos de controles de formularios



Salir
Cuadros de texto: permiten al usuario escribir
información en una línea de texto
Área de texto: permite escribir varias líneas de
texto. La ventana es de tamaño fijo, y para
desplazarse a través de ella se tienen barras de
desplazamiento.
Botón de envío: botón mediante el cual el
usuario envíe toda la información del formulario
(botones Enviar y Enviar imagen).
Menú
Word
Tipos de controles de formularios



Salir
Botón restablecer: permite restaurar los valores
iniciales de los controles
Oculto: utilizado para pasar información al
servidor, por ejemplo, información del entorno
del usuario, cuando el usuario envía el
formulario.
Contraseña: cuadro de texto que muestra
asteriscos (***) para enmascarar el texto que el
usuario escribe
Menú
Word
Insertar controles en un formulario

Para crear un formulario en una página en blanco
o ya existente:
1 seleccionar Ver > Barra de herramientas >
Herramientas Web y asegurarse de estar en Modo
Diseño ( )
2 situarse en el lugar de la página donde se desee
insertar el control (si no está dentro de los límites
del formulario se crea otro nuevo)
3 hacer clic en el control deseado
Salir
Menú
Word
Propiedades de un formulario
Cada campo de un formulario tiene sus propiedades
particulares que definen su nombre, su aspecto y el tipo
de valores que acepta. Para ajustarlas:
1 hacer doble clic sobre el
control (o clic en Propiedades)
2 establecer las propiedades
del control usando cualquiera
de las fichas
3 asignar un nombre a la
propiedad HTLMName de
cada control que se añada
Salir
Menú
Word
Propiedades de un formulario
Los controles pueden contener las propiedades:
 Checked: indica si una casilla de verificación o
un botón de radio están seleccionados
inicialmente
 HTMLName: nombre asociado al control. El
par nombre/valor se enviará al servidor para su
procesamiento
 Value: valor inicial del control. Obligatorio para
el botón de radio
Salir
Menú
Word
Propiedades de un formulario





Salir
MaxLength: válido para cuadros de texto y
contraseñas, indica el número máximo de
caracteres de la entrada
Size: indica el tamaño del cuadro
Columns, Rows: número de columnas y de filas
para áreas de texto
Selected: valor por defecto de la lista
MultiSelected: indica si se permite seleccionar
más de un valor de la lista (que será desplegable)
Menú
Word
Propiedades de un formulario

Salir
DisplayValues: elementos que se mostrarán en
la lista. Introducirlos separados por punto y
coma y sin espacio entre ellos.
Para las listas, el atributo Values indica los
valores asociados a cada elemento de la lista, y
pueden diferir de los valores de presentación,
pero el número de ellos debe ser igual o mayor
que el número de valores de presentación.
Menú
Word
Propiedades de un formulario
Para los botones Enviar y Enviar imagen:
 Action: ubicación del archivo que se abre
cuando el usuario haga clic en Enviar
 Caption: texto que aparece en el botón
 Encoding: tipo de MIME utilizado para
codificar el formulario enviado
 Method: método que se utilizará para enviar el
formulario (POST o GET)
Salir
Menú
Word
Publicar un formulario



Salir
Un formulario requiere un programa CGI en el
servidor web para recibir y procesar la información enviada desde el formulario por el usuario
Word no genera ni instala los programas CGI
necesarios. Hay que usar algún lenguaje de
programación (Perl, C...) para ello.
Se puede configurar el formulario para que los
resultados sean enviados a una cuenta de correo
(Action=mailto:dirección_email ; Method=GET;
Encoding=TEXT/PLAIN)
Menú
Word
Inclusión de otros elementos
Otros elementos que pueden incluirse en las
páginas web:
 secuencias de vídeo
 sonidos
 mapas sensibles
 marcos (frames)
 applets de Java
 ...
Salir
Menú
Word
Secuencias de vídeo

Precaución: los ficheros de vídeo suelen ocupar
mucho espacio. Para insertar un vídeo:
1 seleccionar Ver > Barra de herramientas >
Herramientas Web y hacer clic en el icono Película
2 indicar la ruta del fichero de vídeo (.avi, .mov,
.mpeg...)
3 especificar una imagen alternativa al vídeo, y un
texto alternativo opcional
4 indicar el modo de activación del vídeo y el
número de repeticiones
Salir
Menú
Word
Sonido de fondo

Precaución: un sonido de fondo discordante puede
ser contraproducente. Para agregar un sonido de
fondo:
1 seleccionar Ver > Barra de herramientas >
Herramientas Web y hacer clic en el icono Sonido
2 indicar la ruta del fichero de sonido (.wav, .au,
.midi, .mid...)
3 especificar el número de repeticiones
Salir
Menú
Word
Mapas sensibles

Un mapa sensible es una imagen que dispone
de zonas activas tales que al hacer clic con el
ratón sobre ellas se activa algún enlace.

Word no genera directamente código HTML
para definir mapas sensibles, por lo que habría
que editar el código HTML (p. ej. a través de
Ver > Código HTML), o...
Usar programas expresamente destinados a
ello, como MapEdit o Macromedia Fireworks

Salir
Menú
Word
Crear marcos (frames)

Los marcos o frames dividen la pantalla en
varias ventanas que se definen como páginas
diferentes

Para añadir un marco a una página web:
1 hacer clic en un marco adyacente al lugar en el
que se desea que aparezca el nuevo marco
2 seleccionar Formato > Marcos y escoger la
posición del marco que se desea agregar
3 arrastrar el borde hasta que el marco tenga el
tamaño deseado
Salir
Menú
Word
Crear marcos (frames)

Para especificar la página web inicial que
muestra un marco:
1 hacer clic en el marco
2 seleccionar Formato > Marcos > Propiedades de
marcos > Marco
3 en el cuadro Página inicial, escribir la ruta del
documento que mostrará el marco al abrirlo
Salir
Menú
Word
Crear marcos (frames)

Para asignar un nombre a un marco:
1 hacer clic en el marco
2 seleccionar Formato > Marcos > Propiedades de
marcos > Marco
3 en el cuadro Nombre, escribir el nombre para el
marco
Salir
Menú
Word
Crear marcos (frames)

Para crear un vínculo entre marcos:
1 seleccionar el texto o la imagen que se desee
presentar como hipervínculo
2 seleccionar Insertar > Hipervínculo
3 en la lista Haga clic en el marco en el que desea
que aparezca el documento, escoger el marco
Salir
Menú
Word
Crear marcos (frames)

Para mostrar u ocultar los bordes de los
marcos:
1 seleccionar Formato > Marcos > Propiedades de
marcos
2 en la ficha Bordes, hacer clic en Sin bordes para
desactivar los bordes, o en Mostrar todos los
bordes para activarlos

Para eliminar un marco seleccionado:
1 seleccionar Formato > Marcos > Eliminar marco
Salir
Menú
Word
Insertar applets Java

Java es un lenguaje de programación que
permite incluir programas (applets) en las
páginas web. Tales programas se suelen usar
para conseguir efectos visuales y sonoros

Hay que acudir de nuevo a la codificación en
HTML para insertar applets Java en las páginas
web, ya que Word no lo permite en el modo de
edición web
Salir
Menú
Descargar

Creación de páginas web con Word