Unir Tablas con Shapefiles en gvSIG
NOTA: Asegurarse que las tablas tengan un campo con el que se
pueda indexar, que sea único y coincidente en el archivo xls y en el
shapefile.
ej: código de provincia
2 opciones:
A. Convertir archivo xls en dbf
B. Conexión ODBC al archivo xls
1. Abrir gvSIG y crear la vista con la configuración según la información del SHP
• EPSG: 37717
2. Abrir la vista y cargar el shp «provincias»
1. Abrir gvSIG y crear la vista con la configuración según la información del SHP
• EPSG: 37717
2. Abrir la vista y cargar el shp «provincias»
3. En Gestor de proyectos, añadir una nueva tabla
• Añadir archivo dborig.dbf
1. Abrir gvSIG y crear la vista con la configuración según la información del SHP
• EPSG: 37717
2. Abrir la vista y cargar el shp «provincias»
3. En Gestor de proyectos, añadir una nueva tabla
• Añadir archivo dborig.dbf
4. Regresar a la vista y abrir la tabla de atributos de provincias.shp
1. Abrir gvSIG y crear la vista con la configuración según la información del SHP
2. Abrir la vista y cargar el shp «provincias»
3. En Gestor de proyectos, añadir una nueva tabla
4. Regresar a la vista y abrir la tabla de atributos de provincias.shp
5. En el menu Tabla seleccionar la opción Unir
1. Abrir gvSIG y crear la vista con la configuración según la información del SHP
2. Abrir la vista y cargar el shp «provincias»
3. En Gestor de proyectos, añadir una nueva tabla
4. Regresar a la vista y abrir la tabla de atributos de provincias.shp
5. En el menu Tabla seleccionar la opción Unir
6. En Tabla de origen: seleccionar Tabla de atributos: provincias.shp
Campo a usar para la unión: DPA_PROVIN
- Ejecutar Siguiente
1.
2.
3.
4.
5.
6.
Abrir gvSIG y crear la vista con la configuración según la información del SHP
Abrir la vista y cargar el shp «provincias»
En Gestor de proyectos, añadir una nueva tabla
Regresar a la vista y abrir la tabla de atributos de provincias.shp
En el menu Tabla seleccionar la opción Unir
En Tabla de origen: seleccionar Tabla de atributos: provincias.shp
Campo a usar para la unión: DPA_PROVIN
7. Seleccionar Tabla de destino: dbforig.dbf
Campo a usar para la unión: DPA_PROVIN
- Ejecutar Final
8. RESULTADO:
•
•
A la tabla se incorporan 2 columnas que corresponden a la información en el
archivo dbf
En este caso el nombre de la provincia y el área de la misma
9. Opcional: Clasificar las provincias por el área y representarlo en colores
Metodo B, Conexión ODBC al archivo en xls
1. En Panel de control de Windows seleccionar Orígenes de datos ODBC
2. Agregar
3. Seleccionar Driver do Microsoft Excel(*.xls)
4. Nombre del origen de datos: (cualquier nombre)
• Seleccionar libro
5. Seleccionar el archivo excel que contiene la información a juntar y aceptar
6. Abrir gvSIG y en agregar nueva Tabla
7. Seleccionar la pestaña Base de datos y configurar:
•
•
•
•
Servidor: localhost
Puerto: 8080
Base de datos: ejemplo (nombre que se coloco al origen de datos en ODBC)
Tabla: [area$] (aquí se debe poner el nombre de la hoja en el archivo excel
que contiene la información que deseamos adjuntar)
• Colocar entre corchetes [ ] y con el signo $
• Driver: odbc
Aceptar
8. RESULTADO: la tabla se ha añadido al proyecto
9. Para adjuntar, seguir los pasos del 4 al 9
del ejercicio anterior. Seleccionar la opción:
Localhost:8080/ejemplo Table:[area$] en el paso 7
Opciones de tabla de destino
Descargar

Unir Tablas con Shapefiles en gvSIG