SDL Trados Studio 2009
Opening Single File For Translation
Delivered by
Mgr. Stanislav Pokorný
In this session, you will learn how to:
 Perform basic settings in Studio
 Create a translation memory
 Open and translate a single document
 Save single-document projects
 Revise your translation
 Finalize your translation
Graphic Conventions Used
Explanations are displayed either in plain text or in
bulleted lists
Functions and features are displayed as bulleted lists
Instructions are displayed as ordered (numbered) lists
GUI (graphic user interface) items (i.e. menus and
commands) are displayed in red
Keyboard keys and key shortcuts are displayed bold
Less important information may be included in the notes
below the slides
General Computer Terminology
Please remember the following terminology, as we will be using it
throughout this course:
checkfield = zaškrtávací políčko
radio button = přepínač
group field = skupinový rámeček
menu = nabídka
context menu = místní nabídka
toolbar = panel nástrojů
status bar = stavový řádek
(displayed with a right-click)
Basic Settings
Before using Studio for the first time, it is highly
recommended that you perform some basic settings that
will make your life much easier.
Studio is fully customizable and more than
a thousand different settings are possible. Obviously, we
are not going to explore all of them. We are, however,
going to take a look at the most important ones.
Basic Settings
Launch Studio
To access the Options dialog box, go to Tools > Options
The Options dialog box opens
Basic Settings
The individual settings are grouped under Editor, AutoSuggest, File
Types, Verification, Language Pairs, Colors, Keyboard Shortcuts, and
Translation Memories View
Click the + icon to expand the settings tree for each group
We want to make the following settings:
Editor > Spelling: check all checkfields except for Ignore words in UPPERCASE
Editor > Font Adaptation:
Minimum Font Size = 14
Maximum Font Size = 26
Editor > Automation: check all checkfields except for Copy source when no
match is found
Editor > Auto-propagation:
check all checkfields in the General group box
in the Prompt User group field, select the Conditionally when radio button and check the
Repetition has been translated differently checkfield
Basic Settings Continued
check all checkfields on this page
the AutoSuggest providers should be listed in the following order: Termbases,
AutoSuggest Dictionaries, Auto Text. If they are not, use the Move Up / Move
Down buttons to edit the order in which the providers are listed.
Verification > QA Checker 3.0
Segments Verification: check the Check for forgotten and empty translations
checkfield and select the Error warning level from the dropdown list
Segments to Exclude: check the Exclude Perfect Match units and Exclude
locked segments checkfields
Inconsistencies: set up as shown in the picture below
Basic Settings Continued
Keyboard Shortcuts:
Punctuation: set up as shown in the picture below
Copy Source to Target: set to ALT + INS
QuickPlace: set to CTRL + ALT + Down Arrow
Translation Memories View: check the Show translation unit fields value
column checkfield
Basic Settings: Done
You have now defined all the basic settings that are
essential to get you started with Studio under reasonable
working conditions and with the recommended QA
At this point, you may not fully understand what all the
settings mean or are good for; don’t worry, you will learn
more about them later in this course.
Creating a TM
Before you start translating a file, you first have to create your first
translation memory.
You can create a TM either from the Home View, or during the creation
of a new translation project. We will use the former process.
Go to the Home View and click the New Translation Memory button in
the toolbar. The New Translation Memory dialog box opens.
Type general_engb_cscz into the Name field. “General” means “generic
translation memory”, “engb” means English – Great Britain, and “cscz”
means Czech – Czech Republic.
Type a description to the Description field (optional; e.g. “My first
wonderful translation memory”)
Click the Browse button to specify the location of your new translation
Select the source and the target languages: source language = English
(Great Britain), target language = Czech (Czech Republic)
Click Next >
Creating a TM Continued
The Fields and Settings dialog box opens. Here you can specify descriptive fields
that will be stored with each translation unit. We are going to add the field Status
with three options: New, Approved, and Rejected. This way, we will always know
what status this or that translation unit has.
Click into the Name column and type “Status”
Click into the Type column and select “List”
Click into the Picklist column: type “New” and press TAB, type “Approved” and
press TAB, and type “Rejected” and press TAB. Then click OK in the Picklist
column. Leave the “Allow multiple values” checkfield blank.
Click Next >
Click Finish
Congratulations! You have successfully created your first translation memory.
This translation memory will be used for generic translation projects and each
Translation Unit will be assigned a status: New, or Approved, or Rejected. The
translation memory will be stored on your hard-drive in the location you have
specified in the first window of the wizard.
Creating a TM: Video
Translating a Single Document
Basically, Studio uses project-based approach. This means that Studio regards
each translation, be it 100 or 100,000 words, as a separate project.
However, you don’t need to go through the entire project creation
process, if you want to translate a single document. To make this
scenario easier, Studio includes the Open Document button in the Home
Launch Studio and navigate to the Home View.
Click the Open Document button. The Open Document dialog box opens.
Browse to the first_translation.doc document and click Open.
In the next dialog, you will have to specify the source and the target
languages and select a translation memory that you will use for your
translation. Select English (Great Britain) as the source language and
Czech (Czech Republic) as the target language. Then click Add > Filebased translation memory, browse to our general_engb_cscz.sdltm
translation memory you have just created and click Open. Then click OK.
The document content will be separated from the layout and presented in
the Editor View.
Translating a Single Document
The document is ready for translation, but has not been saved onto your HDD yet.
To do so, click File > Save As and browse to the location where you want your first
project to be saved. In our classroom setup, it is recommended to use the Windows
Desktop (Plocha systému Windows) for that.
As you can see, the Editor View comprises many panes (podokna). These panes
will support you during the translation process. You can undock the panes and
move them around the screen or even to other screens (provided you have multiple
screens connected to your computer, of course). The Translation Results pane
displays the matches (or suggestions) from the translation memory and can be also
used for concordance (manual) search. The Term Recognition pane displays
matches from a terminology database, if your project comprises one.
The text for translation is presented in a side-by-side view: the source text appears
in the left column and you will enter your translations into the right column. The
space between the source and the target columns is used to display translation unit
(TU) information on status, TM match values, and possible errors.
Enter the translation for segment No. 1 into the right-hand column. You will note
that the segment status information (in the middle column) has changed from “Not
Translated” into “Draft”. This will remain so, until you confirm your translation of this
segment. If you want to do so, press CTRL+ALT+ENTER.
Translating a Single Document
The segment status has now changed from “Draft” to “Translated” and your
translation has been saved into your translation memory. Also, note that the
segment No. 4 has been translated automatically, because it is a 100% match with
segment No. 1. This information is shown in the middle column.
This is called “Auto-propagation”.
Translate segment No. 2 and confirm your translation with CTRL+ALT+ENTER.
Translating a Single Document
Translate segment No. 2:
As you can see, there are some purple marks in the source segment that are
missing in the target segment. These marks are called TAGS.
Tags are generally formatting marks, i.e. they carry formatting information of the content between
them. Most tags are used in pairs, i.e. there is one opening and one closing tag. There are some
exceptions, e.g. character entities (the <br /> tag inserts a hard line break, the &ndash; tag inserts
a dash, the &nbsp; tag inserts a non-breakable space between two words, the &scaron; tag
inserts the “š” character under some circumstances etc.).
The general rule says: whenever there is a tag in the source segment, it must be kept in the
target segment too. If you fail to follow this rule, you will break the formatting information of your
translated (target) file and in some cases, Studio may even fail to export your translation into the
target file completely.
If you want to insert the tags, highlight the portion in the target segment you want
to include between the tags and press CTRL+ALT+DOWN ARROW. This will
display the QuickPlace list where you can select the appropriate formatting. Do so
and press ENTER.
Translating a Single Document
Press CTRL+ALT+ENTER to confirm segment No. 2 and to move on to
the next segment.
As you move on to segment No. 5, you are automatically suggested a
possible translation from the TM. The middle column indicates 99%,
which means that the TM stores a match that is 99% similar to the
segment you are currently translating. If you look at the segment more
closely, you will note that the only difference from the previous translation
lies in different formatting, i.e. in the presence of a tag pair. Proceed as
under point 12 to enter the tag pair and confirm this segment with
As you move on to segment No. 6, you are automatically suggested a
possible translation from the TM. The situation is very similar to that
under point 14. Enter the Italics tag pair and move on to the next
Translating a Single Document
As you move on to segment No. 7, you can see that you are automatically
suggested a 92% match. The Translation Results pane is now showing the
difference between your original translation and the current segment:
All you have to do is to replace your original translation „první“ with „druhý“ and
move on to the next segment.
The next segment does contain some differences too, but the meaning is
unchanged. Therefore, we just check this segment and move on to the next one.
Translating a Single Document
The last segment is also suggested, but we can see that there is some difference
in the formatting again. This time, the underlined formatting is applied not only to
the word “extremely” but to the entire phrase “extremely complicated”. Therefore,
we include the word “komplikované” between the tags and delete the same from
behind the closing tag:
Confirm the last segment and you’re done with your first translation.
Checking Your Translation
You have now completed your first translation in Studio, but there are still
some tasks to do before your translation is finally ready to be sent to your
First of all, you need to run the spelling checker to make sure there are no
typos in your translation. To do so, move the cursor at the beginning of the
first segment and press F7. Let the spelling checker correct any mistakes
(just like in MS Word).
Once you are done with that, you should check for any errors and/or
warnings. You can do so by clicking on the Messages tab in the Translation
Results pane. You can see there are two warnings, both of them saying
“Space after tag pair removed”. You can go to the problem locations by
double-clicking the respective warning messages.
The first error appears in segment No. 3 and it is caused by the comma
placed immediately after the closing CF tag. As this comma is required, we
can skip this warning.
The second error appears in segment No. 6 and it is the same as in segment
No. 3. Therefore, we have only received false warnings that we can simply
skip and forget about.
Checking Your Translation
If you like, you can also preview your translation, provided you have Microsoft Office
installed. To do so, move the mouse over the Preview tab in the top-right corner of the
screen, click the Target tab and click the blue link to create a target-language preview.
It should look like this:
If everything looks fine, you can save the target document. Go to File > Save target
as… or press the SHIFT+F12 shortcut. This will save the target document you can
open to perform additional review and/or formatting tasks.
To translate in Studio 2009, you always have
Create a new or assign an existing translation
Specify and import a document for translation
Export your translation into the original format.
Additional tasks:
Always run a spelling checker
Always check for errors and warnings and remove
these, if applicable
Questions? Comments? Feedback?
Please feel free to ask your questions and to
add any comments to what we have done so