Diagramas de Flujo
Símbolo
Significado
Inicio / Fin
Entrada
Salida
Proceso
Si
Decisión
No
Conector
Descripción
Indica el inicio
diagrama de flujo
o
fin
de
un
Se utiliza para la entrada desde
teclado de datos
Se utiliza
resultados
para
la
salida
de
Se
utiliza
para
operaciones,
asignaciones, pasos o procesos en
general
Permite evaluar una condición y
dependiendo del resultado se sigue
por una de las ramas o caminos
alternativos
Conecta partes del diagrama de
flujo
63



Las estructuras de secuencia también son
conocidas como sentencias o proposiciones.
Una sentencia o proposición es una unidad
completa, ejecutable en sí misma.
La ejecución de estas sentencias se realiza de
manera secuencial, es decir, cada una a
continuación de la anterior, empezando por
la primera y terminando con la última.
64
◦ C  a+b
◦ Edad  18
◦ Escribir(«Hola Mundo»)

Proposición Compuesta o bloque
Es un conjunto de declaraciones y sentencias
(proposiciones) agrupadas dentro de los
delimitadores INICIO y FIN:
1. Inicio
2.
X5
3.
Y  89
4. Fin
65



Las estructuras de control, también conocidas
como estructuras de decisión, controlan el
flujo de ejecución de un programa.
Permiten seleccionar la próxima proposición
a ejecutarse dependiendo del valor de una
condición (cierta o falsa).
Para construir esta condición se usarán las
expresiones lógicas o relacionales.
66


1.
2.
Condicional Simple
Se evalúa la condición, si la condición es cierta se
realiza proposición, y si es falsa entonces no se
realiza la proposición.
Sintaxis:
◦ Si condición entonces
proposición
◦ Fin_si
Si (x = y) entonces
Escribir («Las variables x e y tienen el mismo valor»)
Fin_si
67

En diagrama de flujo:
Si
Condición
No
Proposición
68


Condicional doble
Se evalúa la condición, si la condición es
cierta se realizará proposición1 y si condición
es falsa se realizará la proposición2.
Sintaxis:
◦ Si condición entonces
Proposición 1
◦ Si no
Proposición 2
◦ Fin_si
69

En diagrama de flujo:
Si
Proposición 1
Condición
No
Proposición 2
70
1.
2.
3.

Si (x = y) entonces
Escribir («Las variables x e y tienen el mismo valor»)
Si no
Escribir («La variable x tiene un valor distinto al
valor de la variable y»)
Fin_si
Condicional múltiple
Permite realizar una bifurcación múltiple,
ejecutando una entre varias partes del
programa, según se cumpla una entre n
condiciones.
71

Sintaxis:
◦ Según selector sea
Valor1: Hacer proposición 1
Valor2: Hacer proposición 2
Valor3: Hacer proposición 3
.
.
Valor n: Hacer proposición n
[Si no: Hacer proposición x]
◦ Fin_segun
72

En diagrama de flujo:
Selector
Acción 1
Acción 2
….
Acción n
Acción x
73

Inicio
1.
2.
3.
4.
5.
Escribir («Dame la categoría»)
Leer (Categ)
Escribir («Dame el sueldo»)
Leer (sueldo)
Según categ sea
5.1 'A’: sueldo_nuevo  sueldo*0.15
5.2 'B': sueldo_nuevo  sueldo*0.10
5.3 'C': sueldo_nuevo  sueldo*0.7
6. Fin_segun
7. Escribir («Categoria, sueldo», Categ, sueldo_nuevo)

Fin
74



Permiten la ejecución de una lista o secuencia
de instrucciones (bloque de instrucciones) en
varias ocasiones.
El número de veces que el bloque de
instrucciones
se
ejecutará
se
puede
especificar de manera explícita, o a través de
una condición lógica que indica cuándo se
ejecuta de nuevo y cuándo no.
A cada ejecución del bloque de instrucciones
se le conoce como una iteración.
75



El ciclo Para ejecuta un bloque de instrucciones
un número determinado de veces.
Este número de veces está controlado por una
variable contadora (de tipo entero) que toma
valores desde un límite inferior hasta un límite
superior.
En cada ciclo después de ejecutar el bloque de
instrucciones,
la
variable
contadora
es
incrementada en 1 automáticamente y en el
momento en que la variable sobrepasa el límite
superior, el ciclo termina
76

Sintaxis:
◦ para
variable  valor_inicial hasta
[incremento valor_incremento] hacer
valor_final
bloque_de_instrucciones
◦ fin_para


En una instrucción repetitiva Para, siempre se
utiliza una variable a la que se le debe asignar un
valor_inicial.
En cada iteración del bucle, al valor de la variable
se le suma el valor_incremento y, cuando
la variable supera el valor_final, el bucle finaliza.
77
1.
2.
3.
4.

Inicio
para contador  1 hasta 10 incremento 1 hacer
2.1Escribir (contador)
fin_para
Fin
En diagrama de flujo:
78


El ciclo mientras permite ejecutar un bloque
de instrucciones, mientras una expresión
lógica dada se cumpla, es decir, mientras su
evaluación dé como resultado verdadero.
La expresión lógica se denomina condición y
siempre se evalúa antes de ejecutar el bloque
de instrucciones.
◦ Si la condición no se cumple, el bloque no se
ejecuta.
◦ Si la condición se cumple, el bloque se ejecuta,
después de lo cual la instrucción vuelve a empezar,
es decir, la condición se vuelve a evaluar
79


En el caso en que la condición evalúe la
primera vez como falsa, el bloque de
instrucciones no será ejecutado.
Sintaxis:
◦ mientras condición hacer
acciones
◦ fin_mientras
80
1.
2.
3.
4.
Inicio
Escribir («¿hay empleado (s/n)?»)
Leer (otro)
Mientras otro = ’s’ hacer
4.1
4.2
4.3
4.4
4.5
4.6
5.
6.
Escribir («Da nombre, horas trabajadas y cuota»)
Leer (nombre, hrstrab, cuotahr)
sueldo  hrstrab*cuotahr
Escribir (nombre, sueldo)
Escribir(«“¿desea procesar otro empleado (s/n)?»)
Leer (otro)
fin_mientras
Fin
81

Diagramas de flujo:
Condición
Condición
falsa
Condición
verdadera
Acciones
82

Errores en un bucle mientras
◦ No escribir de forma correcta la condición del
bucle, puede producir un bucle infinito.
◦ Inicializar mal la variable que participa en la
condición del bucle.
◦ Olvidarse de escribir alguna instrucción, como
por ejemplo, la instrucción de modificación de la
condición
◦ Como ya se ha dicho, un bucle mientras puede
iterar cero o más veces.
83




En un bucle repetir... hasta, primero se
ejecuta el bloque de instrucciones y, después,
se evalúa la condición.
En el caso de que ésta sea falsa, se vuelve a
ejecutar el bloque de instrucciones.
Y así sucesivamente, hasta que, la condición
sea verdadera.
Por consiguiente, cuando el flujo de un
algoritmo llega a un bucle repetir... hasta,
existen dos posibilidades:
84
◦ Se ejecuta el bloque de instrucciones y, después, si
la condición se evalúa a verdadera, el bloque de
instrucciones no se vuelve a ejecutar, de manera
que, el bucle repetir...hasta finaliza, habiendo
realizado una sola iteración.
◦ Se ejecuta el bloque de instrucciones y, a
continuación, si la condición se evalúa a falsa, el
bloque de instrucciones se vuelve a ejecutar. Y así
sucesivamente, hasta que la condición sea
verdadera.
85
1.
2.
Inicio
repetir
2.1 Escribir («proporcione nombre, número de horas
trabajadas y cuota»)
2.2 Leer (nombre, hrstrab, cuotahr)
2.3 sueldo  hrstrab*cuotahr
2.4 Escribir (nombre, sueldo)
2.5 Escribir («¿desea procesar otro empleado (s/n)?»)
2.6 Leer (desea)
3.
4.
hasta desea = ’n’
Fin
86

Diagramas de flujo:
Acciones
Condición
Condición
falsa
Condición
verdadera
87
Descargar

Diagramas de Flujo