GIMP 2.6
TRATAMIENTO DE LA IMAGEN
DIGITAL
José David Vázquez Delgado
[email protected]
INDICE
INTRODUCCIÓN
1.
•
•
•
2.
3.
4.
5.
6.
7.
8.
9.
10.
11.
Contexto de la herramienta: ¿a quién va dirigido?
¿Qué es?
Propiedades y Capacidades
FORMATOS DE IMAGEN
BUSQUEDA DE IMÁGENES
VENTANAS Y DIÁLOGOS
HERRAMIENTAS DE SELECCIÓN
HERRAMIENTAS DE TRANSFORMACIÓN
HERRAMIENTAS DE PINTURA
CAPAS
HERRAMIENTAS DE AJUSTES
EJERCICIOS
BIBLIOGRAFÍA / WEBGRAFÍA
1. INTRODUCCIÓN
 Contexto
 DECRETO 52/2007, de 17 de mayo, por el que se establece el
currículo de la Educación Secundaria Obligatoria en la Comunidad de
Castilla y León.
 Informática 4º Curso : Bloque 2. Multimedia
 Tratamiento básico de la imagen digital: los formatos básicos
y su aplicación, modificación de tamaño de las imágenes y
selección de fragmentos, creación de dibujos sencillos,
alteración de los parámetros de las fotografías digitales:
saturación, luminosidad y brillo.
1. INTRODUCCIÓN
• ¿Qué es?
• El GIMP(GNU Image Manipulation Program) es una herramienta de
manipulación fotográfica multiplataforma.
• Se puede realizar:
–
–
–
–
retoque fotográfico
composición de imágenes
creación de imágenes
conversión de formatos de imágenes
• Libre disponibilidad desde varias fuentes para muchos
sistemas operativos: GNU/Linux, Microsoft Windows™ o Mac
OS X™(Darwin) de Apple.
1. INTRODUCCIÓN
• Instalación
• Se puede descargar gratuitamente para todas las plataformas
desde: http://www.gimp.org.es/descargar-gimp.html
• Instalar gimp enWindows:
• Ir a la web http://gimp-win.sourceforge.net/stable.html
y pulsar en el enlace “DOWNLOAD“ que encontraréis en el recuadro donde
indica “GIMP for Windows”.
Una vez descargado lo ejecutáis y seguís los pasos, que básicamente es una
sucesión de clics en “Siguiente”.
• Ejecutar Gimp:
• Se inicia pinchando sobre el icono creado en el escritorio o escribiendo
gimp en la línea de comandos.
1. INTRODUCCIÓN
 Propiedades y Capacidades
 Un surtido completo de herramientas de pintura: pincel, un lápiz, un aerógrafo,







clonado, etc.
Gestión de la memoria de mosaico, así que el tamaño de la imagen lo limita sólo
el espacio disponible en el disco
Muestreo de sub-píxel para todas las herramientas de pintura para obtener un
anti-dentado de alta calidad
Asistencia completa del canal alfa para trabajar con transparencia
Capas y canales
Una base de datos de procedimientos para llamar a funciones internas
del GIMP desde programas externos como Script-Fu
Herramientas de transformación: rotar, escalar, inclinar y voltear
Los formatos de archivo soportados incluyen GIF, JPEG, PNG, XPM, TIFF,
TGA, MPEG, PS, PDF, PCX, BMP y muchos otros.
2. FORMATO DE IMAGEN
BMP
Formato nativo de Microsoft Windows .No tiene compresión y mantiene una
calidad media.
JPG
Formato estandarizado que permite compresión de imágenes para así obtener
mayor o menor calidad. Ideal para fotografías. No admite transparencias
GIF
Cuando se trata de imágenes simples o de pocos colores mantendrá los colores
puros del original. Esta limitado a 256 colores. Admite transparencias y
animación.
TIFF
Formato predeterminado para impresión en papel, ideal para archivos muy
pesados. Permite guardar en capas separadas
PSD
Programa estándar del programa Photoshop. Permite guardar en capas
separadas
XFC es la extensión propia de GIMP. Este formato permite guardar información de selecciones,
mascaras, trazados, capas, canales Alpha,etc
3. BÚSQUEDA DE IMÁGENES
 A la hora de buscar imágenes en internet, para luego por ejemplo usar en nuestros apuntes,
tenemos que tener en cuenta el tema del copyright y hacerlo con cuidado.
 Sitios dónde permitan hacerlo:
 Banco de imágenes del Ministerio de Educación. http://bancoimagenes.isftic.mepsyd.es/
 Flickr http://www.flickr.com/ La persona que ha colgado allí sus fotos habrá tenido que
poner que puedes usarlas sin ningún tipo de restricción.
 Wikipedia http://es.wikipedia.orgTenemos que tener en cuenta la imagen con qué tipo de
licencia está publicada
 Google www.google.es
3. BÚSQUEDA DE IMÁGENES
 Otros modos:
 Escaneando fotos mediante un escáner.
 Menú Archivo-Crear- Escáner/Cámara..
 Mediante capturas de pantalla.
 Menú Archivo-Crear- Captura Pantalla..

Te da opciones de capturar la pantalla , o solo la
ventana activa, y además también se puede capturar
después de un determinado tiempo
4. VENTANAS Y DIÁLOGOS
• Como todos los programas GIMP está organizado mediante un
•
•
•
•
•
conjunto de paletas, ventanas y diálogos.
Al abrir GIMP aparece la caja de Herramientas, en ella
encontramos los siguientes elementos:
Las herramientas de selección, dibujo y transformación.
Los colores de frente y fondo. El color de frente es aquel con el
que pintamos cuando utilizamos una herramienta de pintura.
El color de fondo es el que nos muestra el color que tendrá el
"papel" sobre el que vamos a pintar.
En esta zona se pueden añadir elementos interesantes: Desde el
menú Editar -Preferencias -Caja de herramientas marque las
casillas Mostrar pinceles, patrones y degradados activos
y Mostrar imagen activa
Muestra lo siguiente
4. VENTANAS Y DIÁLOGOS
• La segunda ventana importante es la paleta de Capas ,canales y
Rutas, al igual que algunos diálogos relacionados con la
selección de colores, brochas, patrones, gradientes y paletas.
• La ventana de Imagen será nuestra ventana de trabajo, donde
está la imagen activa sobre la que trabajaremos. Desde aquí
aplicaremos efectos, títulos, ajustes, retoques, capas,,,
5. HERRAMIENTAS DE SELECCIÓN
 Herramienta de selección de rectángulos: selecciona una zona rectangular (R)
 Herramienta de selección elíptica: selecciona una zona elíptica (E)
 Herramienta de selección libre o lazo: selecciona una región dibujada a mano (F)
 Herramienta de selección difusa o Varita Mágica: selecciona una región contigua
basándose en el color (U)
 Herramienta de selección por color: seleccionar regiones con colores
similares(Mayúsculas + O)
 Herramienta de tijeras de selección: seleccionar formas usando un ajuste inteligente
de los bordes (I)
5. HERRAMIENTAS DE SELECCIÓN
 Diferentes Modos de Selección:
 Primera opción: Reemplazar la selección actual. Tengo algo
seleccionado, selecciono otro área, y tan sólo queda seleccionada
el segundo área.
 Segunda opción: Añadir a la selección. Tengo algo
seleccionado. Selecciono otro área , y la selección ahora es mayor,
incluye a las dos.
 Tercera opción: restar a la selección.
 Cuarta opción: intersección de selecciones.
Selecciono varias áreas y lo que queda seleccionado es la
intersección de todas ellas.
5. HERRAMIENTAS DE SELECCIÓN
 Al hacer clic sobre cualquier icono de herramienta de selección aparecerá su ventana
de opciones: Las mas destacadas son Alisado y Difuminar.
 Alisado - Suaviza el contorno de la selección
para evitar la clásica forma dentada,
pixelada.
 Difuminar -
Determina un valor de alfa diferente de los píxeles en función de su
distancia al contorno de la selección.
5. HERRAMIENTAS DE SELECCIÓN
 El menú Seleccionar complementa a las opciones y funciones
comentadas hasta ahora.
 Invertir: Selecciona la región, que al efectuar la selección
original, estaba deseleccionada.
 Todos: Selecciona toda la imagen.
 Ninguno: Elimina cualquier selección activa de la imagen
 Flotante: Convierte la selección en capa flotante
 Encoger: Reduce el área de la selección
 Agrandar: Aumenta el área de la selección
 Borde: Crea, a partir de la selección, un grosor determinado
por el valor introducido.
 Guardar en canal: Guarda la selección a un canal
6. HERRAMIENTAS DE TRANSFORMACIÓN
 Herramienta Mover: Mover capas y selecciones y otros objetos (M)
 Herramienta de recorte: Quitar zonas del borde de la capa o de la
imagen(Mayúsculas + C)
 Herramienta de Rotación: Rotar la capa, selección o ruta (Mayúsculas + R)
 Herramienta de Escalado: Escalar la capa, selección o ruta (Mayúsculas + T)
 Herramienta de Inclinación: Inclinar la capa, selección o ruta (Mayúsculas + S)
 Herramienta de Perspectiva: Cambiar la perspectiva de la capa, selección o
ruta(Mayúsculas + P)
 Herramienta de Volteo: Voltea la capa, selección o ruta horizontalmente o
verticalmente (Mayúsculas + F)
7. HERRAMIENTAS DE PINTURA
 Herramienta cubo de pintura: Rellenar con un color o patrón el área
seleccionada(Mayúsculas + B)
 Herramienta degradado: Rellenar con un degradado de colores (L)
 Herramienta lápiz: dibujo de bordes duros mediante un pincel (N)
 Herramienta brocha: pintar trazos de bordes suaves mediante un pincel (P)
 Herramienta borragoma: borra el color de fondo o la transparencia, mediante un
pincel(Mayúsculas + E)
 Herramienta aerógrafo: pintar con presión variable mediante un pincel (A)
 Herramienta bote de tinta: escritura tipo caligrafía (K)
7. HERRAMIENTAS DE PINTURA
 Herramienta de clonado: copiar selectivamente a partir de una imagen o diseño,
usando un pincel (D)
 Herramienta de saneado: sanear irregularidades de la imagen. (H)
 Herramienta de clonado en perspectiva: clona desde una imagen de origen tras
aplicar una transformación de perspectiva
 Herramienta de enfoque y desenfoque: emborronado o desemborronado selectivo
usando un pincel. (Mayúsculas + U)
 Herramienta de emborronar : útil cuando se nos ha podido cortar la imagen, y
queremos arreglarla un poquillo. Para ir rellenando con el mismo color que tenía al
lado (S)
 Herramienta de marcado a fuego / quemar: ilumina u oscurece selectivamente
usando un pincel (Mayúsculas + D)
8. CAPAS
 Las capas son como transparencias que componen la imagen .





Interactúan unas con otras dependiendo de:
Modo. Determina como se combina la capa con las que están
por debajo.
Opacidad. El deslizador permite determinar el grado de
transparencia.
Visibilidad. Si el ojo es visible, la capa es visible. Si pulsas
mayúscula y el ojo de una capa, harás visible esa capa o todas las
capas.
Dónde coloquemos las capas determina el resultado de la
imagen final. Las capas se organizan en forma de pila, la primera
visible al espectador es la ultima que hemos creado
Si la capa no contiene un canal alfa ( canal de transparencia), no
podremos desplazarla verticalmente
1: Para añadir una nueva
capa:
2: subir la capa seleccionada
un nivel más arriba dentro de
la pila de capas
3: bajar la capa seleccionada
más abajo dentro de la pila de
capas.
4: crea un duplicado de la
capa y la añade a la imagen
5: ancla la capa flotante
6: borra la capa seleccionada
8. CAPAS
Añadir una capa de fondo de color
 Añadimos una capa nueva, le damos un color determinado , la
colocamos al final de la pila de capas, y listo:
 1.- Selecciono el color que quiero:
 2. - Creo una capa nueva, y le digo que el fondo sea
del COLOR DE FRENTE .
 3.-Tengo que asegurarme que la capa que acabo de
añadir queda abajo del todo.
9. HERRAMIENTAS DE AJUSTES
 Con esta herramienta conseguiremos :
 Aclarar imágenes oscuras o subexpuestas/Oscurecer imágenes muy claras
 Realzar los detalles en fotografías con poco contraste
 HERRAMIENTA DE NIVELES (MENÚ: COLORES: NIVELES)
 Si abrimos la ventana de niveles, tendremos la información de la
distribución de valores de los píxeles de la imagen, desde el valor negro
hasta el punto de luz más alto[0-255].
 El histograma nos indica la cantidad de color que hay en la imagen. Vemos
que hasta la mitad no hay casi valores.
 Moviendo la flecha vamos ajustando el rango de tonos, mas o menos hasta
donde empieza a haber información de color.
9. HERRAMIENTAS DE AJUSTES
 HERRAMIENTA DE CURVAS (MENÚ: COLORES: CURVAS)
 Permite unos ajustes similares a Niveles , pero puedes ser mucho más
selectivo. Su gráfica está dividida en 16 celdas, y el rango del valor
comprende del 0 a 255.
 Con un clic podemos añadir puntos de control a la curva.
 Ejemplos
 Imagen Original
9. HERRAMIENTAS DE AJUSTES
 HERRAMIENTA TONO Y SATURACIÓN (MENÚ: COLORES:TONO
Y SATURACION)
 Si seleccionamos un color podemos modificar los valores de
tono, luminosidad y saturación sobre ese color.
 Subimos la saturación:
 Si el valor de saturación lo ponemos a -100, lo
convertimos a Blanco y negro
 Imagen original:
9. HERRAMIENTAS DE AJUSTES
 HERRAMIENTA BRILLO Y CONTRASTE (MENÚ: COLORES:
BRILLO Y CONTRASTE)
 HERRAMIENTA POSTERIZAR(MENÚ: COLORES: POSTERIZAR)
 Sirve para bajar el número de colores utilizados en la imagen
9. HERRAMIENTAS DE AJUSTES
 HERRAMIENTA UMBRAL(MENÚ: COLORES: UMBRAL)
 Lo que hace es convertir una imagen en blanco y negro con más o menos
tonos
10. EJERCICIOS DE APLICACIÓN
 He utilizado un blog como herramienta TIC para mostrar
varios ejercicios para aplicar lo estudiado en este tutorial:
 http://tecnoejercicios.blogspot.com
11. Bibliografía/Webgrafía
 http://docs.gimp.org/2.6/es/index.html (21/03/2011)
 http://www.imh.es/dokumentazio-irekia/manuales/curso-
de-tratamiento-de-imagenes-con-gimp (21/03/2011)
 http://tecnomeler.blogspot.com/search/label/gimp
(21/03/2011)
 http://www.jesusda.com/blog/index.php?id=366 (21/03/2011)
 http://www.ite.educacion.es/formacion/enred/ofrecemos/gimp.
php (21/03/2011)